Kaynağa Gözat

all: get rid of kmod-ipv6 dependencies

Signed-off-by: Steven Barth <steven@midlink.org>
Steven Barth 9 yıl önce
ebeveyn
işleme
1d853ac05a

+ 1
- 1
ipv6/tayga/Makefile Dosyayı Görüntüle

@@ -19,7 +19,7 @@ include $(INCLUDE_DIR)/package.mk
19 19
 define Package/tayga
20 20
   SECTION:=net
21 21
   CATEGORY:=Network
22
-  DEPENDS:=+ip +kmod-ipv6 +kmod-tun
22
+  DEPENDS:=+ip @IPV6 +kmod-tun
23 23
   TITLE:=Out-of-kernel stateless NAT64 implementation for Linux
24 24
   URL:=http://www.litech.org/tayga/
25 25
   MAINTAINER:=Ondrej Caletka <ondrej@caletka.cz>

+ 1
- 1
libs/libwebsockets/Makefile Dosyayı Görüntüle

@@ -27,7 +27,7 @@ CMAKE_INSTALL:=1
27 27
 include $(INCLUDE_DIR)/package.mk
28 28
 include $(INCLUDE_DIR)/cmake.mk
29 29
 
30
-CMAKE_OPTIONS += $(if $(CONFIG_PACKAGE_kmod-ipv6),,-DLWS_IPV6=)
30
+CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DLWS_IPV6=)
31 31
 
32 32
 CMAKE_OPTIONS += -DLWS_WITHOUT_TESTAPPS=ON
33 33
 

+ 1
- 1
net/lispmob/Makefile Dosyayı Görüntüle

@@ -33,7 +33,7 @@ define Package/lispd
33 33
   CATEGORY:=Network
34 34
   TITLE:=Locator/ID separation protocol (using TUN)
35 35
   URL:=https://github.com/LISPmob
36
-  DEPENDS:= +librt +libopenssl +confuse +kmod-tun +uci +kmod-ipv6
36
+  DEPENDS:= +librt +libopenssl +confuse +kmod-tun +uci @IPV6
37 37
   $(call Package/lispd/default)
38 38
 endef
39 39
 

+ 1
- 1
net/openvswitch/Makefile Dosyayı Görüntüle

@@ -98,7 +98,7 @@ define KernelPackage/openvswitch
98 98
   SUBMENU:=Network Support
99 99
   TITLE:=Open vSwitch Kernel Package
100 100
   KCONFIG:=CONFIG_BRIDGE
101
-  DEPENDS:=+kmod-stp +kmod-ipv6 +kmod-gre +kmod-lib-crc32c +kmod-vxlan @($(SUPPORTED_KERNELS))
101
+  DEPENDS:=+kmod-stp @IPV6 +kmod-gre +kmod-lib-crc32c +kmod-vxlan @($(SUPPORTED_KERNELS))
102 102
   FILES:= \
103 103
 	$(PKG_BUILD_DIR)/datapath/linux/openvswitch.$(LINUX_KMOD_SUFFIX)
104 104
   AUTOLOAD:=$(call AutoLoad,21,openvswitch)