Browse Source

libarchive: Reduce dependencies by disabling them using configure args

In order to reduce the dependencies, this patch disables following features:
 * Extended Attributes
 * ACL support
 * bzip2 through bz2lib
 * lzop through liblzo2
 * crypto support from Nettle
 * xar through libxml2

Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Johannes Morgenroth 10 years ago
parent
commit
1dc00a2b0a
1 changed files with 9 additions and 1 deletions
  1. 9
    1
      libs/libarchive/Makefile

+ 9
- 1
libs/libarchive/Makefile View File

@@ -30,7 +30,7 @@ endef
30 30
 
31 31
 define Package/libarchive
32 32
   $(call Package/libarchive/Default)
33
-  DEPENDS:=+libxml2 +libopenssl +zlib +libacl +libattr +libbz2 +liblzo +libnettle
33
+  DEPENDS:=+libopenssl +zlib
34 34
   TITLE:=Multi-format archive and compression library
35 35
 endef
36 36
 
@@ -38,6 +38,14 @@ define Package/libarchive/description
38 38
  Multi-format archive and compression library.
39 39
 endef
40 40
 
41
+CONFIGURE_ARGS += \
42
+	--disable-acl \
43
+	--disable-xattr \
44
+	--without-bz2lib \
45
+	--without-lzo2 \
46
+	--without-nettle \
47
+	--without-xml2
48
+
41 49
 define Build/InstallDev
42 50
 	$(INSTALL_DIR) $(1)
43 51
 	$(CP) $(PKG_INSTALL_DIR)/* $(1)/