Procházet zdrojové kódy

rename package name to python3

Agent 42 před 10 roky
rodič
revize
1e6a88dde0
1 změnil soubory, kde provedl 12 přidání a 12 odebrání
  1. 12
    12
      lang/python3/Makefile

+ 12
- 12
lang/python3/Makefile Zobrazit soubor

@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
10 10
 # The file included below defines PYTHON_VERSION
11 11
 -include $(if $(DUMP),,./files/python-package.mk)
12 12
 
13
-PKG_NAME:=python
13
+PKG_NAME:=python3
14 14
 PKG_RELEASE:=1
15 15
 PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
16 16
 
@@ -28,12 +28,12 @@ HOST_BUILD_PARALLEL:=1
28 28
 PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
29 29
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/Python-$(PKG_VERSION)
30 30
 
31
-PKG_BUILD_DEPENDS:=python/host
31
+PKG_BUILD_DEPENDS:=python3/host
32 32
 
33 33
 include $(INCLUDE_DIR)/host-build.mk
34 34
 include $(INCLUDE_DIR)/package.mk
35 35
 
36
-define Package/python/Default
36
+define Package/python3/Default
37 37
   SUBMENU:=Python
38 38
   SECTION:=lang
39 39
   CATEGORY:=Languages
@@ -42,7 +42,7 @@ define Package/python/Default
42 42
   MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
43 43
 endef
44 44
 
45
-define Package/python/Default/description
45
+define Package/python3/Default/description
46 46
  Python is a dynamic object-oriented programming language that can be used
47 47
  for many kinds of software development. It offers strong support for
48 48
  integration with other languages and tools, comes with extensive standard
@@ -51,13 +51,13 @@ define Package/python/Default/description
51 51
  the development of higher quality, more maintainable code.
52 52
 endef
53 53
 
54
-define Package/python
55
-$(call Package/python/Default)
54
+define Package/python3
55
+$(call Package/python3/Default)
56 56
   DEPENDS:=+libpthread +zlib +libffi
57 57
 endef
58 58
 
59
-define Package/python/description
60
-$(call Package/python/Default/description)
59
+define Package/python3/description
60
+$(call Package/python3/Default/description)
61 61
   .
62 62
   This package contains only the interpreter and the bare minimum for the interpreter to start.
63 63
 endef
@@ -137,7 +137,7 @@ define Build/InstallDev
137 137
 	ln -sf python$(PYTHON_VERSION)-config python-config;)
138 138
 endef
139 139
 
140
-define PyPackage/python/filespec
140
+define PyPackage/python3/filespec
141 141
 +|/usr/bin/python$(PYTHON_VERSION)
142 142
 +|/usr/lib/python$(PYTHON_VERSION)/encodings
143 143
 +|/usr/lib/python$(PYTHON_VERSION)/_collections_abc.py
@@ -155,7 +155,7 @@ define PyPackage/python/filespec
155 155
 +|/usr/lib/python$(PYTHON_VERSION)/stat.py
156 156
 endef
157 157
 
158
-define PyPackage/python/install
158
+define PyPackage/python3/install
159 159
 	# Adding the lib-dynload folder (even just empty) suppresses 2 warnings when starting Python
160 160
 	$(INSTALL_DIR) $(1)/usr/lib/python$(PYTHON_VERSION)/lib-dynload/
161 161
 	ln -sf python$(PYTHON_VERSION) $(1)/usr/bin/python
@@ -194,6 +194,6 @@ endef
194 194
 
195 195
 $(eval $(call HostBuild))
196 196
 
197
-$(eval $(call PyPackage,python))
197
+$(eval $(call PyPackage,python3))
198 198
 
199
-$(eval $(call BuildPackage,python))
199
+$(eval $(call BuildPackage,python3))