Quellcode durchsuchen

python-pip: remove windows binaries

Seem pip comes bundled with some Python libs.

Some more work will be needed to split them out of pip.
For now, some Windows executables are safe to remove.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean vor 10 Jahren
Ursprung
Commit
1ee71252e7
1 geänderte Dateien mit 3 neuen und 1 gelöschten Zeilen
  1. 3
    1
      lang/python-pip/Makefile

+ 3
- 1
lang/python-pip/Makefile Datei anzeigen

@@ -40,8 +40,10 @@ define Build/Compile
40 40
 	)
41 41
 endef
42 42
 
43
+PYTHON_PIP_PKG_DIR:=$(PYTHON_PKG_DIR)/pip-$(PKG_VERSION)-py$(PYTHON_VERSION).egg/pip
43 44
 define PyPackage/python-pip/filespec
44
-+|/usr/lib/python$(PYTHON_VERSION)
45
++|$(PYTHON_PKG_DIR)
46
+-|$(PYTHON_PIP_PKG_DIR)/_vendor/distlib/*.exe
45 47
 endef
46 48
 
47 49
 # Backup these files, so that they do not clash with python-setuptools