Browse Source

dropped gcrypt variant for now

now using libnettle for the default crypto library

Signed-off-by: Christian Pointner <equinox@spreadspace.org>
Christian Pointner 10 years ago
parent
commit
1f60e90a9d
1 changed files with 8 additions and 7 deletions
  1. 8
    7
      net/uanytun/Makefile

+ 8
- 7
net/uanytun/Makefile View File

@@ -12,12 +12,12 @@
12 12
 include $(TOPDIR)/rules.mk
13 13
 
14 14
 PKG_NAME:=uanytun
15
-PKG_VERSION:=0.3.4
15
+PKG_VERSION:=0.3.5
16 16
 PKG_RELEASE:=1
17 17
 
18 18
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
19 19
 PKG_SOURCE_URL:=http://www.anytun.org/download/
20
-PKG_MD5SUM:=b4085ab7f0127732818b8b801f280aef
20
+PKG_MD5SUM:=ce47ad45003ff1d84eaf5276941b9ddf
21 21
 
22 22
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
23 23
 
@@ -37,9 +37,9 @@ endef
37 37
 
38 38
 define Package/uanytun
39 39
   $(call Package/uanytun/template)
40
-  TITLE+= (gcrypt)
41
-  VARIANT:=gcrypt
42
-  DEPENDS+=+libgcrypt
40
+  TITLE+= (nettle)
41
+  VARIANT:=nettle
42
+  DEPENDS+=+libnettle
43 43
 endef
44 44
 
45 45
 define Package/uanytun/conffiles
@@ -101,8 +101,9 @@ VARIANT_CFLAGS:=
101 101
 VARIANT_LDFLAGS:=-ldl
102 102
 VARIANT_MAKE_OPTS:=
103 103
 
104
-ifeq ($(BUILD_VARIANT),gcrypt)
105
-VARIANT_LDFLAGS+=-lgpg-error -lgcrypt
104
+ifeq ($(BUILD_VARIANT),nettle)
105
+VARIANT_CFLAGS+=-DUSE_NETTLE
106
+VARIANT_LDFLAGS+=-lnettle
106 107
 endif
107 108
 
108 109
 ifeq ($(BUILD_VARIANT),sslcrypt)