Browse Source

net/bind: add the bind user/group

Signed-off-by: Noah Meyerhans <frodo@morgul.net>
Noah Meyerhans 10 years ago
parent
commit
1fe4160fc2
2 changed files with 4 additions and 1 deletions
  1. 2
    1
      net/bind/Makefile
  2. 2
    0
      net/bind/files/named.init

+ 2
- 1
net/bind/Makefile View File

@@ -10,7 +10,8 @@ include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=bind
12 12
 PKG_VERSION:=9.9.6-P1
13
-PKG_RELEASE:=1
13
+PKG_RELEASE:=2
14
+USERID:=bind=57:bind=57
14 15
 
15 16
 PKG_MAINTAINER := Noah Meyerhans <frodo@morgul.net>
16 17
 PKG_LICENSE := BSD-3-Clause

+ 2
- 0
net/bind/files/named.init View File

@@ -26,6 +26,8 @@ fix_perms() {
26 26
 }
27 27
 
28 28
 start_service() {
29
+    user_exists bind 57 || user_add bind 57
30
+    group_exists bind 57 || group_add bind 57
29 31
     fix_perms
30 32
     procd_open_instance
31 33
     procd_set_param command /usr/sbin/named -u bind -f -c $config_file