Browse Source

mwan3: update to version 1.5-9

Fix issue where config file would be overwritten in some cases
Fix issue where local address of wan point-to-point links were unreachable from lan

Signed-off-by: Jeroen Louwes <jeroen.louwes@gmail.com>
Adze1502 10 years ago
parent
commit
1ff50d94dc
2 changed files with 7 additions and 3 deletions
  1. 3
    3
      net/mwan3/Makefile
  2. 4
    0
      net/mwan3/files/etc/hotplug.d/iface/15-mwan3

+ 3
- 3
net/mwan3/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=mwan3
11 11
 PKG_VERSION:=1.5
12
-PKG_RELEASE:=8
12
+PKG_RELEASE:=9
13 13
 PKG_MAINTAINER:=Jeroen Louwes <jeroen.louwes@gmail.com>
14 14
 PKG_LICENSE:=GPLv2
15 15
 
@@ -32,14 +32,14 @@ interfaces, connection tracking and an easy to manage traffic ruleset.
32 32
 endef
33 33
 
34 34
 define Package/mwan3/conffiles
35
-   /etc/config/mwan3
35
+/etc/config/mwan3
36 36
 endef
37 37
 
38 38
 define Build/Compile
39 39
 endef
40 40
 
41 41
 define Package/mwan3/install
42
-   $(CP) ./files/* $(1)
42
+$(CP) ./files/* $(1)
43 43
 endef
44 44
 
45 45
 $(eval $(call BuildPackage,mwan3))

+ 4
- 0
net/mwan3/files/etc/hotplug.d/iface/15-mwan3 View File

@@ -71,6 +71,10 @@ mwan3_set_connected_iptables()
71 71
 			$IPT -A mwan3_connected -d $connected_networks -j MARK --set-xmark 0xff00/0xff00
72 72
 		done
73 73
 
74
+		for connected_networks in $($IP route list table 0 | awk '{print $2}' | egrep '[0-9]{1,3}(\.[0-9]{1,3}){3}'); do
75
+			$IPT -A mwan3_connected -d $connected_networks -j MARK --set-xmark 0xff00/0xff00
76
+		done
77
+
74 78
 		$IPT -I mwan3_connected -d 224.0.0.0/3 -j MARK --set-xmark 0xff00/0xff00
75 79
 		$IPT -I mwan3_connected -d 127.0.0.0/8 -j MARK --set-xmark 0xff00/0xff00
76 80
 	fi