Browse Source

dump1090: remove interactive options, hardcode quiet and add respawn config.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Álvaro Fernández Rojas 10 years ago
parent
commit
1ffcf17b02

+ 1
- 1
utils/dump1090/Makefile View File

@@ -8,7 +8,7 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=dump1090
11
-PKG_VERSION:=2014-10-25
11
+PKG_VERSION:=2014-10-27
12 12
 PKG_RELEASE:=$(PKG_SOURCE_VERSION)
13 13
 
14 14
 PKG_SOURCE_PROTO:=git

+ 1
- 5
utils/dump1090/files/dump1090.config View File

@@ -1,14 +1,11 @@
1 1
 config dump1090 main
2 2
 	option disabled '1'
3
+	option respawn '1'
3 4
 	option device_index ''
4 5
 	option gain ''
5 6
 	option enable_agc '0'
6 7
 	option freq ''
7 8
 	option ifile ''
8
-	option interactive '0'
9
-	option interactive_rows ''
10
-	option interactive_ttl ''
11
-	option interactive_rtl1090 '0'
12 9
 	option raw '0'
13 10
 	option net '1'
14 11
 	option modeac '0'
@@ -38,5 +35,4 @@ config dump1090 main
38 35
 	option metric '0'
39 36
 	option snip ''
40 37
 	option debug ''
41
-	option quiet '1'
42 38
 	option ppm ''

+ 7
- 7
utils/dump1090/files/dump1090.init View File

@@ -29,23 +29,21 @@ append_bool() {
29 29
 
30 30
 start_instance() {
31 31
 	local cfg="$1"
32
+	local aux
32 33
 
33
-	config_get_bool disabled "$cfg" 'disabled' '0'
34
-	[ "$disabled" = 1 ] && return 1
34
+	config_get_bool aux "$cfg" 'disabled' '0'
35
+	[ "$aux" = 1 ] && return 1
35 36
 
36 37
 	procd_open_instance
37 38
 
38 39
 	procd_set_param command /usr/bin/dump1090
40
+	procd_append_param command "--quiet"
39 41
 
40 42
 	append_arg "$cfg" device_index "--device-index"
41 43
 	append_arg "$cfg" gain "--gain"
42 44
 	append_bool "$cfg" enable_agc "--enable-agc"
43 45
 	append_arg "$cfg" freq "--freq"
44 46
 	append_arg "$cfg" ifile "--ifile"
45
-	append_bool "$cfg" interactive "--interactive"
46
-	append_arg "$cfg" interactive_rows "--interactive-rows"
47
-	append_arg "$cfg" interactive_ttl "--interactive-ttl"
48
-	append_bool "$cfg" interactive_rtl1090 "--interactive-rtl1090"
49 47
 	append_bool "$cfg" raw "--raw"
50 48
 	append_bool "$cfg" net "--net"
51 49
 	append_bool "$cfg" modeac "--modeac"
@@ -75,9 +73,11 @@ start_instance() {
75 73
 	append_bool "$cfg" metric "--metric"
76 74
 	append_arg "$cfg" snip "--snip"
77 75
 	append_arg "$cfg" debug "--debug"
78
-	append_bool "$cfg" quiet "--quiet"
79 76
 	append_arg "$cfg" ppm "--ppm"
80 77
 
78
+	config_get_bool aux "$cfg" 'respawn' '0'
79
+	[ "$aux" = 1 ] && procd_set_param respawn
80
+
81 81
 	procd_close_instance
82 82
 }
83 83