소스 검색

libmpdclient: Add patch for musl libc compatibility (from upstream repo)

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 10 년 전
부모
커밋
2017a0f6e2
2개의 변경된 파일23개의 추가작업 그리고 1개의 파일을 삭제
  1. 1
    1
      libs/libmpdclient/Makefile
  2. 22
    0
      libs/libmpdclient/patches/001-WIP_musl_compatibility.patch

+ 1
- 1
libs/libmpdclient/Makefile 파일 보기

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libmpdclient
11 11
 PKG_VERSION:=2.9
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
15 15
 PKG_SOURCE_URL:=http://www.musicpd.org/download/libmpdclient/2/

+ 22
- 0
libs/libmpdclient/patches/001-WIP_musl_compatibility.patch 파일 보기

@@ -0,0 +1,22 @@
1
+--- a/src/socket.c
2
++++ b/src/socket.c
3
+@@ -43,6 +43,7 @@
4
+ #else
5
+ #  include <netinet/in.h>
6
+ #  include <arpa/inet.h>
7
++#  include <sys/select.h>
8
+ #  include <sys/socket.h>
9
+ #  include <netdb.h>
10
+ #  include <sys/un.h>
11
+--- a/src/sync.c
12
++++ b/src/sync.c
13
+@@ -33,6 +33,9 @@
14
+ #include <assert.h>
15
+ #include <stdlib.h>
16
+ #include <stdio.h>
17
++#ifndef WIN32
18
++#include <sys/select.h>
19
++#endif
20
+ #include <fcntl.h>
21
+ #include <unistd.h>
22
+