Browse Source

ocserv: added option to use seccomp

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Nikos Mavrogiannopoulos 10 years ago
parent
commit
201ef91c32
3 changed files with 12 additions and 1 deletions
  1. 4
    0
      net/ocserv/Config.in
  2. 6
    1
      net/ocserv/Makefile
  3. 2
    0
      net/ocserv/files/ocserv.conf.template

+ 4
- 0
net/ocserv/Config.in View File

@@ -7,6 +7,10 @@ config OCSERV_PAM
7 7
 	bool "enable PAM"
8 8
 	default n
9 9
 
10
+config OCSERV_SECCOMP
11
+	bool "enable seccomp"
12
+	default n
13
+
10 14
 config OCSERV_PROTOBUF
11 15
 	bool "use external libprotobuf"
12 16
 	default y

+ 6
- 1
net/ocserv/Makefile View File

@@ -22,6 +22,7 @@ PKG_FIXUP:=autoreconf
22 22
 
23 23
 PKG_CONFIG_DEPENDS:= \
24 24
 	CONFIG_OCSERV_PAM \
25
+	CONFIG_OCSERV_SECCOMP \
25 26
 	CONFIG_OCSERV_PROTOBUF \
26 27
 
27 28
 include $(INCLUDE_DIR)/package.mk
@@ -37,7 +38,7 @@ define Package/ocserv
37 38
   TITLE:=OpenConnect VPN server
38 39
   URL:=http://www.infradead.org/ocserv/
39 40
   MAINTAINER:=Nikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>
40
-  DEPENDS:= +OCSERV_HTTP_PARSER:libhttp-parser +libgnutls +certtool +libncurses +libreadline +OCSERV_PAM:libpam +OCSERV_PROTOBUF:libprotobuf-c +kmod-tun
41
+  DEPENDS:= +OCSERV_HTTP_PARSER:libhttp-parser +OCSERV_SECCOMP:libseccomp +libgnutls +certtool +libncurses +libreadline +OCSERV_PAM:libpam +OCSERV_PROTOBUF:libprotobuf-c +kmod-tun
41 42
   USERID:=ocserv=72:ocserv=72
42 43
 endef
43 44
 
@@ -62,6 +63,10 @@ ifneq ($(CONFIG_OCSERV_PAM),y)
62 63
 CONFIGURE_ARGS += --without-pam
63 64
 endif
64 65
 
66
+ifneq ($(CONFIG_OCSERV_SECCOMP),y)
67
+CONFIGURE_ARGS += --disable-seccomp
68
+endif
69
+
65 70
 ifneq ($(CONFIG_OCSERV_PROTOBUF),y)
66 71
 CONFIGURE_ARGS += --without-protobuf
67 72
 endif

+ 2
- 0
net/ocserv/files/ocserv.conf.template View File

@@ -18,6 +18,8 @@ auth = "|AUTH|"
18 18
 # A banner to be displayed on clients
19 19
 banner = "Welcome to OpenWRT"
20 20
 
21
+isolate-workers = true
22
+
21 23
 # When the server has a dynamic DNS address (that may change),
22 24
 # should set that to true to ask the client to resolve again on
23 25
 # reconnects.