Browse Source

ruby: Disable doc generation

Docs are not currently packaged. So, there is no need to install
them. Also, doxygen have some problem with the usaged of git in
build_dir as it takes ages running git commands on every file.
Disabling the docs reduces the compilation time.

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
Luiz Angelo Daros de Luca 10 years ago
parent
commit
205becb6e8
1 changed files with 3 additions and 1 deletions
  1. 3
    1
      lang/ruby/Makefile

+ 3
- 1
lang/ruby/Makefile View File

@@ -16,7 +16,7 @@ include $(TOPDIR)/rules.mk
16 16
 
17 17
 PKG_NAME:=ruby
18 18
 PKG_VERSION:=2.1.2
19
-PKG_RELEASE:=2
19
+PKG_RELEASE:=3
20 20
 
21 21
 PKG_LIBVER:=2.1
22 22
 
@@ -210,6 +210,8 @@ CONFIGURE_ARGS += \
210 210
 	--enable-static \
211 211
 	--disable-rpath \
212 212
 	--enable-ipv6 \
213
+	--disable-install-doc \
214
+	--disable-install-capi \
213 215
 	--with-ruby-version=minor \
214 216
 	--with-iconv-dir=$(ICONV_PREFIX) \
215 217