瀏覽代碼

perl-http-date: New package

Signed-off-by: Marcel Denia <naoir@gmx.net>
Marcel Denia 9 年之前
父節點
當前提交
21435c966b
共有 1 個檔案被更改,包括 48 行新增0 行删除
  1. 48
    0
      lang/perl-http-date/Makefile

+ 48
- 0
lang/perl-http-date/Makefile 查看文件

@@ -0,0 +1,48 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=perl-http-date
11
+PKG_VERSION:=6.02
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=http://www.cpan.org/authors/id/G/GA/GAAS
15
+PKG_SOURCE:=HTTP-Date-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=52b7a0d5982d61be1edb217751d7daba
17
+
18
+PKG_LICENSE:=GPL-1.0+ Artistic-1.0-Perl
19
+PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
20
+
21
+PKG_BUILD_DIR:=$(BUILD_DIR)/perl/HTTP-Date-$(PKG_VERSION)
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+include ../perl/perlmod.mk
25
+
26
+define Package/perl-http-date
27
+  SUBMENU:=Perl
28
+  SECTION:=lang
29
+  CATEGORY:=Languages
30
+  TITLE:=Date conversion routines
31
+  URL:=http://search.cpan.org/dist/HTTP-Date/
32
+  DEPENDS:=perl
33
+endef
34
+
35
+define Build/Configure
36
+        $(call perlmod/Configure,,)
37
+endef
38
+
39
+define Build/Compile
40
+        $(call perlmod/Compile,,)
41
+endef
42
+
43
+define Package/perl-http-date/install
44
+        $(call perlmod/Install,$(1),HTTP auto/HTTP)
45
+endef
46
+
47
+
48
+$(eval $(call BuildPackage,perl-http-date))