|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2008-2014 OpenWrt.org
|
|
2
|
+# Copyright (C) 2008-2015 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=gst1-plugins-base
|
11
|
11
|
PKG_VERSION:=1.4.4
|
12
|
|
-PKG_RELEASE:=1
|
|
12
|
+PKG_RELEASE:=2
|
13
|
13
|
|
14
|
14
|
PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
15
|
15
|
|
|
@@ -33,6 +33,7 @@ PKG_CONFIG_DEPENDS:= \
|
33
|
33
|
CONFIG_PACKAGE_gst1-mod-ogg \
|
34
|
34
|
CONFIG_PACKAGE_gst1-mod-tcp \
|
35
|
35
|
CONFIG_PACKAGE_gst1-mod-theora \
|
|
36
|
+ CONFIG_PACKAGE_gst1-mod-videoconvert \
|
36
|
37
|
CONFIG_PACKAGE_gst1-mod-videotestsrc \
|
37
|
38
|
CONFIG_PACKAGE_gst1-mod-volume \
|
38
|
39
|
CONFIG_PACKAGE_gst1-mod-vorbis \
|
|
@@ -134,6 +135,7 @@ CONFIGURE_ARGS += \
|
134
|
135
|
$(call GST_COND_SELECT,theora) \
|
135
|
136
|
--disable-videorate \
|
136
|
137
|
--disable-videoscale \
|
|
138
|
+ $(call GST_COND_SELECT,videoconvert) \
|
137
|
139
|
$(call GST_COND_SELECT,videotestsrc) \
|
138
|
140
|
$(call GST_COND_SELECT,volume) \
|
139
|
141
|
$(call GST_COND_SELECT,vorbis) \
|
|
@@ -275,6 +277,7 @@ $(eval $(call GstBuildPlugin,ogg,Ogg,riff tag pbutils video,,+libogg))
|
275
|
277
|
$(eval $(call GstBuildPlugin,tcp,TCP,,,))
|
276
|
278
|
$(eval $(call GstBuildPlugin,theora,Theora,tag video,,+libogg +libtheora))
|
277
|
279
|
$(eval $(call GstBuildPlugin,typefindfunctions,'typefind' functions,audio pbutils tag video,,))
|
|
280
|
+$(eval $(call GstBuildPlugin,videoconvert,video format conversion,video,,))
|
278
|
281
|
$(eval $(call GstBuildPlugin,videotestsrc,video test,video,,+liboil))
|
279
|
282
|
$(eval $(call GstBuildPlugin,volume,volume,audio controller,,+liboil))
|
280
|
283
|
$(eval $(call GstBuildPlugin,vorbis,Vorbis,audio tag,ogg,+libvorbis))
|