Ver código fonte

hamlib: Update to v3.0.1

Signed-off-by: Vasilis Tsiligiannis <acinonyx@openwrt.gr>
Vasilis Tsiligiannis 8 anos atrás
pai
commit
22204c07d7

+ 12
- 441
utils/hamlib/Makefile Ver arquivo

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2014 OpenWrt.org
2
+# Copyright (C) 2014-2016 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -7,9 +7,9 @@
7 7
 include $(TOPDIR)/rules.mk
8 8
 
9 9
 PKG_NAME:=hamlib
10
-PKG_VERSION:=1.2.15.3
11
-PKG_RELEASE:=3
12
-PKG_MD5SUM:=3cad8987e995a00e5e9d360e2be0eb43
10
+PKG_VERSION:=3.0.1
11
+PKG_RELEASE:=1
12
+PKG_MD5SUM:=451acb9f727ed706ae2f59ee3f0e03c7
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=@SF/hamlib
@@ -39,7 +39,7 @@ define Package/hamlib
39 39
   TITLE+= utilities
40 40
   SECTION:=utils
41 41
   CATEGORY:=Utilities
42
-  DEPENDS:=+libpthread +libhamlib
42
+  DEPENDS:=+libhamlib
43 43
 endef
44 44
 
45 45
 define Package/hamlib/description
@@ -57,7 +57,7 @@ endef
57 57
 
58 58
 define Package/libhamlib
59 59
   $(call Package/libhamlib/Default)
60
-  DEPENDS:=+libusb-1.0 +libltdl
60
+  DEPENDS:=+libusb-1.0
61 61
   MENU:=1
62 62
 endef
63 63
 
@@ -67,222 +67,6 @@ define Package/libhamlib/description
67 67
   This package contains the hamlib shared library.
68 68
 endef
69 69
 
70
-define Package/hamlib-adat
71
-  $(call Package/libhamlib/Default)
72
-  TITLE:= for ADAT
73
-  DEPENDS:=libhamlib
74
-endef
75
-
76
-define Package/hamlib-alinco
77
-  $(call Package/libhamlib/Default)
78
-  TITLE:= for Alinco
79
-  DEPENDS:=libhamlib
80
-endef
81
-
82
-define Package/hamlib-amsat
83
-  $(call Package/libhamlib/Default)
84
-  TITLE:= for AMSAT
85
-  DEPENDS:=libhamlib
86
-endef
87
-
88
-define Package/hamlib-aor
89
-  $(call Package/libhamlib/Default)
90
-  TITLE:= for AOR
91
-  DEPENDS:=libhamlib
92
-endef
93
-
94
-define Package/hamlib-ars
95
-  $(call Package/libhamlib/Default)
96
-  TITLE:= for ARS
97
-  DEPENDS:=libhamlib
98
-endef
99
-
100
-define Package/hamlib-celestron
101
-  $(call Package/libhamlib/Default)
102
-  TITLE:= for Celestron
103
-  DEPENDS:=libhamlib
104
-endef
105
-
106
-define Package/hamlib-drake
107
-  $(call Package/libhamlib/Default)
108
-  TITLE:= for Drake
109
-  DEPENDS:=libhamlib
110
-endef
111
-
112
-define Package/hamlib-dummy
113
-  $(call Package/libhamlib/Default)
114
-  TITLE:= for dummy
115
-  DEPENDS:=libhamlib
116
-endef
117
-
118
-define Package/hamlib-easycomm
119
-  $(call Package/libhamlib/Default)
120
-  TITLE:= for EasyComm
121
-  DEPENDS:=libhamlib
122
-endef
123
-
124
-define Package/hamlib-flexradio
125
-  $(call Package/libhamlib/Default)
126
-  TITLE:= for FlexRadio
127
-  DEPENDS:=libhamlib
128
-endef
129
-
130
-define Package/hamlib-fodtrack
131
-  $(call Package/libhamlib/Default)
132
-  TITLE:= for FodTrack
133
-  DEPENDS:=libhamlib
134
-endef
135
-
136
-define Package/hamlib-gs232a
137
-  $(call Package/libhamlib/Default)
138
-  TITLE:= for GS-232A
139
-  DEPENDS:=libhamlib
140
-endef
141
-
142
-define Package/hamlib-heathkit
143
-  $(call Package/libhamlib/Default)
144
-  TITLE:= for Heathkit
145
-  DEPENDS:=libhamlib
146
-endef
147
-
148
-define Package/hamlib-icom
149
-  $(call Package/libhamlib/Default)
150
-  TITLE:= for ICOM
151
-  DEPENDS:=libhamlib
152
-endef
153
-
154
-define Package/hamlib-jrc
155
-  $(call Package/libhamlib/Default)
156
-  TITLE:= for JRC
157
-  DEPENDS:=libhamlib
158
-endef
159
-
160
-define Package/hamlib-kachina
161
-  $(call Package/libhamlib/Default)
162
-  TITLE:= for Kachina
163
-  DEPENDS:=libhamlib
164
-endef
165
-
166
-define Package/hamlib-kenwood
167
-  $(call Package/libhamlib/Default)
168
-  TITLE:= for Kenwood
169
-  DEPENDS:=libhamlib
170
-endef
171
-
172
-define Package/hamlib-kit
173
-  $(call Package/libhamlib/Default)
174
-  TITLE:= for kits
175
-  DEPENDS:=libhamlib
176
-endef
177
-
178
-define Package/hamlib-lowe
179
-  $(call Package/libhamlib/Default)
180
-  TITLE:= for Lowe
181
-  DEPENDS:=libhamlib
182
-endef
183
-
184
-define Package/hamlib-m2
185
-  $(call Package/libhamlib/Default)
186
-  TITLE:= for M2
187
-  DEPENDS:=libhamlib
188
-endef
189
-
190
-define Package/hamlib-pcr
191
-  $(call Package/libhamlib/Default)
192
-  TITLE:= for PCR
193
-  DEPENDS:=libhamlib
194
-endef
195
-
196
-define Package/hamlib-prm80
197
-  $(call Package/libhamlib/Default)
198
-  TITLE:= for PRM80
199
-  DEPENDS:=libhamlib
200
-endef
201
-
202
-define Package/hamlib-racal
203
-  $(call Package/libhamlib/Default)
204
-  TITLE:= for Racal
205
-  DEPENDS:=libhamlib
206
-endef
207
-
208
-define Package/hamlib-rft
209
-  $(call Package/libhamlib/Default)
210
-  TITLE:= for RFT
211
-  DEPENDS:=libhamlib
212
-endef
213
-
214
-define Package/hamlib-rotorez
215
-  $(call Package/libhamlib/Default)
216
-  TITLE:= for Rotor-EZ
217
-  DEPENDS:=libhamlib
218
-endef
219
-
220
-define Package/hamlib-rs
221
-  $(call Package/libhamlib/Default)
222
-  TITLE:= for R&S
223
-  DEPENDS:=libhamlib
224
-endef
225
-
226
-define Package/hamlib-sartek
227
-  $(call Package/libhamlib/Default)
228
-  TITLE:= for SARtek
229
-  DEPENDS:=libhamlib
230
-endef
231
-
232
-define Package/hamlib-skanti
233
-  $(call Package/libhamlib/Default)
234
-  TITLE:= for Skanti
235
-  DEPENDS:=libhamlib
236
-endef
237
-
238
-define Package/hamlib-spid
239
-  $(call Package/libhamlib/Default)
240
-  TITLE:= for SPID
241
-  DEPENDS:=libhamlib
242
-endef
243
-
244
-define Package/hamlib-tapr
245
-  $(call Package/libhamlib/Default)
246
-  TITLE:= for TAPR
247
-  DEPENDS:=libhamlib
248
-endef
249
-
250
-define Package/hamlib-tentec
251
-  $(call Package/libhamlib/Default)
252
-  TITLE:= for TenTec
253
-  DEPENDS:=libhamlib
254
-endef
255
-
256
-define Package/hamlib-ts7400
257
-  $(call Package/libhamlib/Default)
258
-  TITLE:= for TS-7400
259
-  DEPENDS:=libhamlib
260
-endef
261
-
262
-define Package/hamlib-tuner
263
-  $(call Package/libhamlib/Default)
264
-  TITLE:= for Video for Linux tuner
265
-  DEPENDS:=libhamlib
266
-endef
267
-
268
-define Package/hamlib-uniden
269
-  $(call Package/libhamlib/Default)
270
-  TITLE:= for Uniden
271
-  DEPENDS:=libhamlib
272
-endef
273
-
274
-define Package/hamlib-wj
275
-  $(call Package/libhamlib/Default)
276
-  TITLE:= for Watkins - Johnson
277
-  DEPENDS:=libhamlib
278
-endef
279
-
280
-define Package/hamlib-yaesu
281
-  $(call Package/libhamlib/Default)
282
-  TITLE:= for Yaesu
283
-  DEPENDS:=libhamlib
284
-endef
285
-
286 70
 define Build/InstallDev
287 71
 	$(INSTALL_DIR) $(1)/usr/include/hamlib
288 72
 	$(CP) $(PKG_INSTALL_DIR)/usr/include/hamlib/*.h $(1)/usr/include/hamlib
@@ -293,11 +77,15 @@ define Build/InstallDev
293 77
 endef
294 78
 
295 79
 CONFIGURE_ARGS+= \
80
+	--disable-html-matrix \
81
+	--disable-winradio \
82
+	--without-readline \
296 83
 	--without-cxx-binding \
297
-	--without-winradio \
298
-	--without-rpc-backends \
299 84
 	--with-pic \
300 85
 
86
+CONFIGURE_VARS+= \
87
+	LIBUSB_LIBS="-lusb-1.0" \
88
+
301 89
 define Package/hamlib/install
302 90
 	$(INSTALL_DIR) $(1)/usr/bin
303 91
 	$(CP) $(PKG_INSTALL_DIR)/usr/bin/{rig,rot}* $(1)/usr/bin/
@@ -308,222 +96,5 @@ define Package/libhamlib/install
308 96
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libhamlib.so* $(1)/usr/lib/
309 97
 endef
310 98
 
311
-define Package/hamlib-adat/install
312
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
313
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-adat.so* $(1)/usr/lib/hamlib
314
-endef
315
-
316
-define Package/hamlib-alinco/install
317
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
318
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-alinco.so* $(1)/usr/lib/hamlib
319
-endef
320
-
321
-define Package/hamlib-amsat/install
322
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
323
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-amsat.so* $(1)/usr/lib/hamlib
324
-endef
325
-
326
-define Package/hamlib-aor/install
327
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
328
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-aor.so* $(1)/usr/lib/hamlib
329
-endef
330
-
331
-define Package/hamlib-ars/install
332
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
333
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-ars.so* $(1)/usr/lib/hamlib
334
-endef
335
-
336
-define Package/hamlib-celestron/install
337
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
338
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-celestron.so* $(1)/usr/lib/hamlib
339
-endef
340
-
341
-define Package/hamlib-drake/install
342
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
343
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-drake.so* $(1)/usr/lib/hamlib
344
-endef
345
-
346
-define Package/hamlib-dummy/install
347
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
348
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-dummy.so* $(1)/usr/lib/hamlib
349
-endef
350
-
351
-define Package/hamlib-easycomm/install
352
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
353
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-easycomm.so* $(1)/usr/lib/hamlib
354
-endef
355
-
356
-define Package/hamlib-flexradio/install
357
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
358
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-flexradio.so* $(1)/usr/lib/hamlib
359
-endef
360
-
361
-define Package/hamlib-fodtrack/install
362
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
363
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-fodtrack.so* $(1)/usr/lib/hamlib
364
-endef
365
-
366
-define Package/hamlib-gs232a/install
367
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
368
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-gs232a.so* $(1)/usr/lib/hamlib
369
-endef
370
-
371
-define Package/hamlib-heathkit/install
372
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
373
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-heathkit.so* $(1)/usr/lib/hamlib
374
-endef
375
-
376
-define Package/hamlib-icom/install
377
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
378
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-icom.so* $(1)/usr/lib/hamlib
379
-endef
380
-
381
-define Package/hamlib-jrc/install
382
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
383
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-jrc.so* $(1)/usr/lib/hamlib
384
-endef
385
-
386
-define Package/hamlib-kachina/install
387
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
388
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-kachina.so* $(1)/usr/lib/hamlib
389
-endef
390
-
391
-define Package/hamlib-kenwood/install
392
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
393
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-kenwood.so* $(1)/usr/lib/hamlib
394
-endef
395
-
396
-define Package/hamlib-kit/install
397
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
398
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-kit.so* $(1)/usr/lib/hamlib
399
-endef
400
-
401
-define Package/hamlib-lowe/install
402
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
403
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-lowe.so* $(1)/usr/lib/hamlib
404
-endef
405
-
406
-define Package/hamlib-m2/install
407
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
408
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-m2.so* $(1)/usr/lib/hamlib
409
-endef
410
-
411
-define Package/hamlib-pcr/install
412
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
413
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-pcr.so* $(1)/usr/lib/hamlib
414
-endef
415
-
416
-define Package/hamlib-prm80/install
417
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
418
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-prm80.so* $(1)/usr/lib/hamlib
419
-endef
420
-
421
-define Package/hamlib-racal/install
422
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
423
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-racal.so* $(1)/usr/lib/hamlib
424
-endef
425
-
426
-define Package/hamlib-rft/install
427
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
428
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-rft.so* $(1)/usr/lib/hamlib
429
-endef
430
-
431
-define Package/hamlib-rotorez/install
432
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
433
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-rotorez.so* $(1)/usr/lib/hamlib
434
-endef
435
-
436
-define Package/hamlib-rs/install
437
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
438
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-rs.so* $(1)/usr/lib/hamlib
439
-endef
440
-
441
-define Package/hamlib-sartek/install
442
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
443
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-sartek.so* $(1)/usr/lib/hamlib
444
-endef
445
-
446
-define Package/hamlib-skanti/install
447
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
448
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-skanti.so* $(1)/usr/lib/hamlib
449
-endef
450
-
451
-define Package/hamlib-spid/install
452
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
453
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-spid.so* $(1)/usr/lib/hamlib
454
-endef
455
-
456
-define Package/hamlib-tapr/install
457
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
458
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-tapr.so* $(1)/usr/lib/hamlib
459
-endef
460
-
461
-define Package/hamlib-tentec/install
462
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
463
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-tentec.so* $(1)/usr/lib/hamlib
464
-endef
465
-
466
-define Package/hamlib-ts7400/install
467
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
468
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-ts7400.so* $(1)/usr/lib/hamlib
469
-endef
470
-
471
-define Package/hamlib-tuner/install
472
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
473
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-tuner.so* $(1)/usr/lib/hamlib
474
-endef
475
-
476
-define Package/hamlib-uniden/install
477
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
478
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-uniden.so* $(1)/usr/lib/hamlib
479
-endef
480
-
481
-define Package/hamlib-wj/install
482
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
483
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-wj.so* $(1)/usr/lib/hamlib
484
-endef
485
-
486
-define Package/hamlib-yaesu/install
487
-	$(INSTALL_DIR) $(1)/usr/lib/hamlib
488
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/hamlib/hamlib-yaesu.so* $(1)/usr/lib/hamlib
489
-endef
490
-
491 99
 $(eval $(call BuildPackage,hamlib))
492 100
 $(eval $(call BuildPackage,libhamlib))
493
-$(eval $(call BuildPackage,hamlib-adat))
494
-$(eval $(call BuildPackage,hamlib-alinco))
495
-$(eval $(call BuildPackage,hamlib-amsat))
496
-$(eval $(call BuildPackage,hamlib-aor))
497
-$(eval $(call BuildPackage,hamlib-ars))
498
-$(eval $(call BuildPackage,hamlib-celestron))
499
-$(eval $(call BuildPackage,hamlib-drake))
500
-$(eval $(call BuildPackage,hamlib-dummy))
501
-$(eval $(call BuildPackage,hamlib-easycomm))
502
-$(eval $(call BuildPackage,hamlib-flexradio))
503
-$(eval $(call BuildPackage,hamlib-fodtrack))
504
-$(eval $(call BuildPackage,hamlib-gs232a))
505
-$(eval $(call BuildPackage,hamlib-heathkit))
506
-$(eval $(call BuildPackage,hamlib-icom))
507
-$(eval $(call BuildPackage,hamlib-jrc))
508
-$(eval $(call BuildPackage,hamlib-kachina))
509
-$(eval $(call BuildPackage,hamlib-kenwood))
510
-$(eval $(call BuildPackage,hamlib-kit))
511
-$(eval $(call BuildPackage,hamlib-lowe))
512
-$(eval $(call BuildPackage,hamlib-m2))
513
-$(eval $(call BuildPackage,hamlib-pcr))
514
-$(eval $(call BuildPackage,hamlib-prm80))
515
-$(eval $(call BuildPackage,hamlib-racal))
516
-$(eval $(call BuildPackage,hamlib-rft))
517
-$(eval $(call BuildPackage,hamlib-rotorez))
518
-$(eval $(call BuildPackage,hamlib-rs))
519
-$(eval $(call BuildPackage,hamlib-sartek))
520
-$(eval $(call BuildPackage,hamlib-skanti))
521
-$(eval $(call BuildPackage,hamlib-spid))
522
-$(eval $(call BuildPackage,hamlib-tapr))
523
-$(eval $(call BuildPackage,hamlib-tentec))
524
-$(eval $(call BuildPackage,hamlib-ts7400))
525
-$(eval $(call BuildPackage,hamlib-tuner))
526
-$(eval $(call BuildPackage,hamlib-uniden))
527
-$(eval $(call BuildPackage,hamlib-wj))
528
-$(eval $(call BuildPackage,hamlib-yaesu))
529
-

+ 0
- 30
utils/hamlib/patches/100-override-autoconf-detection.patch Ver arquivo

@@ -1,30 +0,0 @@
1
-Index: hamlib-1.2.15.3/configure.ac
2
-===================================================================
3
---- hamlib-1.2.15.3.orig/configure.ac	2012-11-01 22:27:27.000000000 +0100
4
-+++ hamlib-1.2.15.3/configure.ac	2014-06-15 09:34:25.557966205 +0200
5
-@@ -234,12 +234,12 @@
6
- 		"You need a C99 compliant C compiler that supports struct/array intializers."
7
- 		"Have you considered GCC lately?.")]);
8
- 
9
--dnl libxml2 required rigmem xml support
10
--PKG_CHECK_MODULES([LIBXML2], [libxml-2.0],
11
--	[AC_DEFINE(HAVE_XML2,[1],[Define if libxml2 is available])],
12
--	[AC_MSG_WARN([libxml-2.0 pkg-config not found, XML support will be disabled])])
13
-+#dnl libxml2 required rigmem xml support
14
-+#PKG_CHECK_MODULES([LIBXML2], [libxml-2.0],
15
-+#	[AC_DEFINE(HAVE_XML2,[1],[Define if libxml2 is available])],
16
-+#	[AC_MSG_WARN([libxml-2.0 pkg-config not found, XML support will be disabled])])
17
- AC_SUBST(LIBXML2_LIBS)
18
- AC_SUBST(LIBXML2_CFLAGS)
19
- 
20
- dnl Check if libgd-dev is installed, so we can enable rigmatrix
21
- 
22
-@@ -406,7 +406,7 @@
23
- AM_CONDITIONAL(HAVE_USRP, test x"${cf_with_usrp}" = "xyes")
24
- 
25
- 
26
--PKG_CHECK_MODULES(LIBUSB, libusb >= 0.1, ,
27
-+PKG_CHECK_MODULES(LIBUSB, libusb >= 1.0, ,
28
- 		  [AC_MSG_WARN([libusb pkg-config not found, USB backends will be disabled])])
29
- CFLAGS="${CFLAGS} ${LIBUSB_CFLAGS}"
30
- CXXFLAGS="${CXXFLAGS} ${LIBUSB_CFLAGS}"