Ver código fonte

ntpd: add libcap to default dependencies of the ntpd package

Seems ntpdate also requires this lib:
```
Package ntpdate is missing dependencies for the following libraries:
libcap.so.2
make[2]: *** [/store/buildbot/slave/ar71xx/build/bin/ar71xx/packages/packages/ntpdate_4.2.8p4-1_ar71xx.ipk] Error 1
make[2]: Leaving directory `/store/buildbot/slave/ar71xx/build/feeds/packages/net/ntpd'
```

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 9 anos atrás
pai
commit
2238ccc7c2
1 arquivos alterados com 3 adições e 5 exclusões
  1. 3
    5
      net/ntpd/Makefile

+ 3
- 5
net/ntpd/Makefile Ver arquivo

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ntp
11 11
 PKG_VERSION:=4.2.8p4
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://www.eecis.udel.edu/~ntp/ntp_spool/ntp4/ntp-4.2/
@@ -31,7 +31,7 @@ define Package/ntpd/Default
31 31
   TITLE:=ISC ntp
32 32
   MAINTAINER:=Peter Wagner <tripolar@gmx.at>
33 33
   URL:=http://www.ntp.org/
34
-  DEPENDS:=+libopenssl +libpthread
34
+  DEPENDS:=+libopenssl +libpthread +libcap
35 35
 endef
36 36
 
37 37
 define Package/ntpd/Default/description
@@ -43,7 +43,6 @@ endef
43 43
 define Package/ntpd
44 44
 $(call Package/ntpd/Default)
45 45
   TITLE+= server
46
-  DEPENDS+= +libcap
47 46
   USERID:=ntp=123:ntp=123
48 47
 endef
49 48
 
@@ -67,7 +66,6 @@ endef
67 66
 define Package/ntp-utils
68 67
 $(call Package/ntpd/Default)
69 68
   TITLE+= utilities
70
-  DEPENDS+= +libcap
71 69
 endef
72 70
 
73 71
 define Package/ntp-utils/description
@@ -79,7 +77,7 @@ endef
79 77
 define Package/ntp-keygen
80 78
 $(call Package/ntpd/Default)
81 79
   TITLE+=keygen
82
-  DEPENDS+= +libcap +libevent2-core
80
+  DEPENDS+= +libevent2-core
83 81
 endef
84 82
 
85 83
 define Package/ntp-keygen/description