|
@@ -0,0 +1,92 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2012 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=alsa-utils
|
|
11
|
+PKG_VERSION:=1.0.27.2
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
15
|
+PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/utils/ \
|
|
16
|
+ http://alsa.cybermirror.org/utils/
|
|
17
|
+PKG_MD5SUM:=b65e9a04181bd7c9db7667a4566f8dc3
|
|
18
|
+PKG_INSTALL:=1
|
|
19
|
+
|
|
20
|
+include $(INCLUDE_DIR)/package.mk
|
|
21
|
+
|
|
22
|
+define Package/alsa-utils
|
|
23
|
+ SECTION:=utils
|
|
24
|
+ CATEGORY:=Utilities
|
|
25
|
+ DEPENDS:=+alsa-lib +libncurses +libpthread
|
|
26
|
+ TITLE:=ALSA (Advanced Linux Sound Architecture) utilities
|
|
27
|
+ URL:=http://www.alsa-project.org/
|
|
28
|
+endef
|
|
29
|
+
|
|
30
|
+define Package/alsa-utils-seq
|
|
31
|
+ SECTION:=utils
|
|
32
|
+ CATEGORY:=Utilities
|
|
33
|
+ DEPENDS:=+alsa-lib +libpthread
|
|
34
|
+ TITLE:=ALSA sequencer utilities
|
|
35
|
+ URL:=http://www.alsa-project.org/
|
|
36
|
+endef
|
|
37
|
+
|
|
38
|
+define Package/alsa-utils-tests
|
|
39
|
+ $(call Package/alsa-utils/Default)
|
|
40
|
+ SECTION:=utils
|
|
41
|
+ CATEGORY:=Utilities
|
|
42
|
+ TITLE:=ALSA utilities test data (adds ~1.3M to image)
|
|
43
|
+ DEPENDS:=+alsa-lib +libpthread
|
|
44
|
+endef
|
|
45
|
+
|
|
46
|
+define Build/Configure
|
|
47
|
+ $(call Build/Configure/Default, \
|
|
48
|
+ --disable-rpath \
|
|
49
|
+ --disable-alsatest \
|
|
50
|
+ --disable-xmlto \
|
|
51
|
+ , \
|
|
52
|
+ ac_cv_prog_ncurses5_config=no \
|
|
53
|
+ ac_cv_prog_ncursesw5_config=no \
|
|
54
|
+ )
|
|
55
|
+endef
|
|
56
|
+
|
|
57
|
+define Package/alsa-utils/install
|
|
58
|
+ $(INSTALL_DIR) $(1)/usr/{s,}bin
|
|
59
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/amixer $(1)/usr/bin/
|
|
60
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/alsamixer $(1)/usr/bin/
|
|
61
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aplay $(1)/usr/bin/
|
|
62
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/arecord $(1)/usr/bin/
|
|
63
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/alsactl $(1)/usr/sbin/
|
|
64
|
+
|
|
65
|
+ $(INSTALL_DIR) $(1)/usr/share/alsa/init
|
|
66
|
+ $(INSTALL_DATA) \
|
|
67
|
+ $(PKG_INSTALL_DIR)/usr/share/alsa/init/* \
|
|
68
|
+ $(1)/usr/share/alsa/init/
|
|
69
|
+endef
|
|
70
|
+
|
|
71
|
+define Package/alsa-utils-seq/install
|
|
72
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
73
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aconnect $(1)/usr/bin/
|
|
74
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/amidi $(1)/usr/bin/
|
|
75
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aplaymidi $(1)/usr/bin/
|
|
76
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/arecordmidi $(1)/usr/bin/
|
|
77
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aseqdump $(1)/usr/bin/
|
|
78
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/aseqnet $(1)/usr/bin/
|
|
79
|
+endef
|
|
80
|
+
|
|
81
|
+define Package/alsa-utils-tests/install
|
|
82
|
+ $(INSTALL_DIR) $(1)/usr/{s,}bin
|
|
83
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/speaker-test $(1)/usr/bin/
|
|
84
|
+ $(INSTALL_DIR) $(1)/usr/share/sounds/alsa
|
|
85
|
+ $(INSTALL_DATA) \
|
|
86
|
+ $(PKG_INSTALL_DIR)/usr/share/sounds/alsa/* \
|
|
87
|
+ $(1)/usr/share/sounds/alsa/
|
|
88
|
+endef
|
|
89
|
+
|
|
90
|
+$(eval $(call BuildPackage,alsa-utils))
|
|
91
|
+$(eval $(call BuildPackage,alsa-utils-seq))
|
|
92
|
+$(eval $(call BuildPackage,alsa-utils-tests))
|