Преглед изворни кода

rng-tools: musl compatibility

Make rng-tools to compile with musl
by adding similar argp dependencies as with uclibc.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
Hannu Nyman пре 9 година
родитељ
комит
23334b9816
1 измењених фајлова са 8 додато и 3 уклоњено
  1. 8
    3
      utils/rng-tools/Makefile

+ 8
- 3
utils/rng-tools/Makefile Прегледај датотеку

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2011-2014 OpenWrt.org
2
+# Copyright (C) 2011-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=rng-tools
11 11
 PKG_VERSION:=5
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=@SF/gkernel/rng-tools/$(PKG_VERSION)/
@@ -19,7 +19,7 @@ PKG_MAINTAINER:=Hannu Nyman <hannu.nyman@iki.fi>
19 19
 
20 20
 PKG_FIXUP:=autoreconf
21 21
 
22
-PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone
22
+PKG_BUILD_DEPENDS:=USE_UCLIBC:argp-standalone USE_MUSL:argp-standalone
23 23
 
24 24
 include $(INCLUDE_DIR)/package.mk
25 25
 
@@ -35,6 +35,11 @@ CONFIGURE_VARS += \
35 35
     LIBS="-largp"
36 36
 endif
37 37
 
38
+ifdef CONFIG_USE_MUSL
39
+CONFIGURE_VARS += \
40
+    LIBS="-largp"
41
+endif
42
+
38 43
 CONFIGURE_ARGS += \
39 44
 	--without-libgcrypt
40 45