Browse Source

joe: bump to upstream v4.1

Signed-off-by: Vitaly Protsko <villy@sft.ru>
---
 Makefile |   11 ++++-------
 1 file changed, 4 insertions(+), 7 deletions(-)
aTanW 9 years ago
parent
commit
2463ea5f64
1 changed files with 4 additions and 7 deletions
  1. 4
    7
      utils/joe/Makefile

+ 4
- 7
utils/joe/Makefile View File

@@ -20,15 +20,15 @@
20 20
 include $(TOPDIR)/rules.mk
21 21
 
22 22
 PKG_NAME:=joe
23
-PKG_VERSION:=4.0
24
-PKG_RELEASE:=4
23
+PKG_VERSION:=4.1
24
+PKG_RELEASE:=1
25 25
 
26 26
 PKG_SOURCE_URL:=@SF/joe-editor
27 27
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
28
-PKG_MD5SUM:=3c3b6d5089a29ddc746ee89bab59286e
28
+PKG_MD5SUM:=b8c9ab4295e3208ddbbaa9c1141564f9
29 29
 PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
30 30
 PKG_MAINTAINER:=Vitaly Protsko <villy@sft.ru>
31
-PKG_LICENCE:=GPL-1.0
31
+PKG_LICENCE:=GPL-2.0
32 32
 
33 33
 include $(INCLUDE_DIR)/package.mk
34 34
 
@@ -49,9 +49,6 @@ endef
49 49
 define Package/joe/install
50 50
 	$(INSTALL_DIR) $(1)/usr/bin
51 51
 	$(INSTALL_BIN) $(PKG_BUILD_DIR)/joe/joe $(1)/usr/bin/
52
-	for i in jmacs jstar rjoe jpico; do \
53
-	  ln -sf joe $(1)/usr/bin/$$$$i; \
54
-	done
55 52
 	$(INSTALL_DIR) $(1)/etc/joe
56 53
 	$(INSTALL_CONF) ./files/joerc $(1)/etc/joe/joerc
57 54
 endef