|
@@ -8,15 +8,15 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=libsearpc
|
11
|
|
-PKG_VERSION:=3.0-latest
|
12
|
|
-PKG_RELEASE:=1
|
|
11
|
+PKG_VERSION:=3.1.7
|
|
12
|
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
|
13
|
13
|
PKG_LICENSE:=GPL-3.0
|
14
|
14
|
|
15
|
|
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
16
|
|
-PKG_SOURCE:=v$(PKG_VERSION).tar.gz
|
17
|
|
-PKG_SOURCE_URL:=https://github.com/haiwen/libsearpc/archive/
|
18
|
|
-PKG_MD5SUM:=32a6eaafe16d8c0c0e320b4a08a4d8f6
|
19
|
|
-PKG_CAT:=zcat
|
|
15
|
+PKG_SOURCE_PROTO:=git
|
|
16
|
+PKG_SOURCE_URL:=https://github.com/haiwen/libsearpc.git
|
|
17
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
18
|
+PKG_SOURCE_VERSION:=8998e7b2c5587f0b94c48db24e2952d08def5add
|
|
19
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
20
|
20
|
PKG_FIXUP:=autoreconf
|
21
|
21
|
PKG_INSTALL:=1
|
22
|
22
|
|
|
@@ -58,13 +58,6 @@ endef
|
58
|
58
|
|
59
|
59
|
$(eval $(call HostBuild))
|
60
|
60
|
|
61
|
|
-Hooks/Prepare/Post += delete_source_package
|
62
|
|
-
|
63
|
|
-define delete_source_package
|
64
|
|
- # deleting source package as its filename is ambiguous
|
65
|
|
- rm -f $(DL_DIR)/$(PKG_SOURCE)
|
66
|
|
-endef
|
67
|
|
-
|
68
|
61
|
define Build/InstallDev
|
69
|
62
|
$(INSTALL_DIR) $(1)/usr/{bin,include}
|
70
|
63
|
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|