Bladeren bron

cyrus-sasl: fix typo in install section

An overly specific glob pattern in the package install sections prevents
the unversioned .so symlinks from getting copied into the .ipk.

This commit changes the pattern from xxx.so.* to xxx.so* in order to copy
those symlinks too. Fixes #382.

Also bump the copyright year in the Makefile while we're at it.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich 10 jaren geleden
bovenliggende
commit
259b47ac6f
1 gewijzigde bestanden met toevoegingen van 4 en 4 verwijderingen
  1. 4
    4
      libs/cyrus-sasl/Makefile

+ 4
- 4
libs/cyrus-sasl/Makefile Bestand weergeven

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006-2008 OpenWrt.org
2
+# Copyright (C) 2006-2014 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=cyrus-sasl
11 11
 PKG_VERSION:=2.1.26
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
15 15
 
@@ -104,9 +104,9 @@ endef
104 104
 
105 105
 define Package/libsasl2/install
106 106
 	$(INSTALL_DIR) $(1)/usr/lib/
107
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsasl2.so.* $(1)/usr/lib/
107
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsasl2.so* $(1)/usr/lib/
108 108
 	$(INSTALL_DIR) $(1)/usr/lib/sasl2
109
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/sasl2/lib*.so.* $(1)/usr/lib/sasl2/
109
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/sasl2/lib*.so* $(1)/usr/lib/sasl2/
110 110
 endef
111 111
 
112 112
 $(eval $(call BuildPackage,libsasl2))