Przeglądaj źródła

iotivity: add IoTivity

IoTivity is a Internet of Things framework implementing the Open
Interconnect Consortium Specification.

The current version of IoTivity is still in heavy development and does
not support all its intended features, but I still want to add it to
the packages feed to make it easier for others to extend the OpenWrt
support.

Signed-off-by: Hauke Mehrtens <hauke.mehrtens@lantiq.com>
Hauke Mehrtens 9 lat temu
rodzic
commit
2627b0ea50

+ 216
- 0
net/iotivity/Makefile Wyświetl plik

@@ -0,0 +1,216 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=iotivity
11
+PKG_VERSION:=0.9.1
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_PROTO:=git
15
+PKG_SOURCE_URL:=https://gerrit.iotivity.org/gerrit/iotivity
16
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
17
+PKG_SOURCE_VERSION:=0.9.1
18
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
19
+PKG_MIRROR_MD5SUM:=
20
+PKG_USE_MIPS16:=0
21
+
22
+PKG_MAINTAINER:=Hauke Mehrtens <hauke.mehrtens@lantiq.com>
23
+
24
+PKG_LICENSE:=Apache-2.0
25
+PKG_LICENSE_FILES:=LICENSE.md
26
+
27
+PKG_BUILD_DEPENDS:= +boost +libexpat
28
+
29
+include $(INCLUDE_DIR)/package.mk
30
+include $(INCLUDE_DIR)/scons.mk
31
+
32
+
33
+define Package/iotivity
34
+  SECTION:=net
35
+  CATEGORY:=Network
36
+  DEPENDS:= +libpthread +librt +libstdcpp +libuuid
37
+  TITLE:=IoTivity Library
38
+  URL:=https://www.iotivity.org
39
+endef
40
+
41
+define Package/iotivity/description
42
+    IoTivity is a framework for the Internet of Things based on the
43
+    Open Interconnect Consortium Specification.
44
+endef
45
+
46
+
47
+define Package/iotivity-things-manager-lib
48
+  SECTION:=net
49
+  CATEGORY:=Network
50
+  DEPENDS:=iotivity
51
+  TITLE:=IoTivity things manager lib
52
+  URL:=https://www.iotivity.org
53
+endef
54
+
55
+define Package/iotivity-things-manager-lib/description
56
+    IoTivity things-manager lib
57
+endef
58
+
59
+
60
+define Package/iotivity-plugin-manager-lib
61
+  SECTION:=net
62
+  CATEGORY:=Network
63
+  DEPENDS:=iotivity +libexpat
64
+  TITLE:=IoTivity plugin manager lib
65
+  URL:=https://www.iotivity.org
66
+endef
67
+
68
+define Package/iotivity-plugin-manager-lib/description
69
+    IoTivity plugin manager lib
70
+endef
71
+
72
+
73
+define Package/iotivity-mqttclient
74
+  SECTION:=net
75
+  CATEGORY:=Network
76
+  DEPENDS:=iotivity +iotivity-plugin-manager-lib +boost +boost-system
77
+  TITLE:=IoTivity mqtt Client
78
+  URL:=https://www.iotivity.org
79
+endef
80
+
81
+define Package/iotivity-mqttclient/description
82
+    IoTivity mqtt Client
83
+endef
84
+
85
+
86
+define Package/iotivity-oic-middle
87
+  SECTION:=net
88
+  CATEGORY:=Network
89
+  DEPENDS:=iotivity
90
+  TITLE:=IoTivity OIC Middle
91
+  URL:=https://www.iotivity.org
92
+endef
93
+
94
+define Package/iotivity-oic-middle/description
95
+    IoTivity OIC Middle
96
+endef
97
+
98
+
99
+define Package/iotivity-things-manager
100
+  SECTION:=net
101
+  CATEGORY:=Network
102
+  DEPENDS:=iotivity +iotivity-things-manager-lib
103
+  TITLE:=IoTivity things manager
104
+  URL:=https://www.iotivity.org
105
+endef
106
+
107
+define Package/iotivity-things-manager/description
108
+    IoTivity things manager
109
+endef
110
+
111
+
112
+define Package/iotivity-example-garage
113
+  SECTION:=net
114
+  CATEGORY:=Network
115
+  DEPENDS:=iotivity
116
+  TITLE:=IoTivity Garage example
117
+  URL:=https://www.iotivity.org
118
+endef
119
+
120
+define Package/iotivity-example-garage/description
121
+    An IoTivity example application
122
+endef
123
+
124
+
125
+PKG_CEREAL_NAME:=cereal
126
+PKG_CEREAL_VERSION:=7121e91e6ab8c3e6a6516d9d9c3e6804e6f65245
127
+PKG_CEREAL_SOURCE:=$(PKG_CEREAL_NAME)-$(PKG_CEREAL_VERSION).tar.bz2
128
+PKG_CEREAL_PROTO:=git
129
+PKG_CEREAL_SOURCE_URL:=https://github.com/USCiLab/cereal.git
130
+PKG_CEREAL_SUBDIR:=$(PKG_CEREAL_NAME)
131
+#PKG_CEREAL_MIRROR_MD5SUM:=?
132
+
133
+define Download/iotivity-cereal
134
+  FILE:=$(PKG_CEREAL_SOURCE)
135
+  URL:=$(PKG_CEREAL_SOURCE_URL)
136
+  PROTO:=$(PKG_CEREAL_PROTO)
137
+  VERSION:=$(PKG_CEREAL_VERSION)
138
+  SUBDIR:=$(PKG_CEREAL_SUBDIR)
139
+  #MIRROR_MD5SUM:=$(PKG_CEREAL_MIRROR_MD5SUM)
140
+endef
141
+$(eval $(call Download,iotivity-cereal))
142
+
143
+
144
+SCONS_OPTIONS += \
145
+	TARGET_OS=linux \
146
+	TARGET_TRANSPORT=ALL \
147
+	TARGET_ARCH=$(ARCH) \
148
+	STAGING_DIR=$(STAGING_DIR) \
149
+	mqttclient examples samples libTGMSDK ConServerApp ConClientApp BootstrapServerApp
150
+
151
+ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
152
+  SCONS_OPTIONS += VERBOSE=true
153
+endif
154
+
155
+define Build/Prepare
156
+	$(call Build/Prepare/Default)
157
+	$(TAR) -C $(PKG_BUILD_DIR)/extlibs/cereal -xjf $(DL_DIR)/$(PKG_CEREAL_SOURCE)
158
+endef
159
+
160
+define Build/Configure
161
+	(cd $(PKG_BUILD_DIR); \
162
+		$(SCONS_VARS) \
163
+		scons \
164
+			$(SCONS_OPTIONS) \
165
+	)
166
+endef
167
+
168
+
169
+define Package/iotivity/install
170
+	$(INSTALL_DIR) $(1)/usr/lib
171
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/out/linux/$(ARCH)/release/liboc.so $(1)/usr/lib/liboc.so
172
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/out/linux/$(ARCH)/release/liboc_logger.so $(1)/usr/lib/liboc_logger.so
173
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/out/linux/$(ARCH)/release/liboctbstack.so $(1)/usr/lib/liboctbstack.so
174
+endef
175
+
176
+define Package/iotivity-things-manager-lib/install
177
+	$(INSTALL_DIR) $(1)/usr/lib
178
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/out/linux/$(ARCH)/release/libTGMSDKLibrary.so $(1)/usr/lib/libTGMSDKLibrary.so
179
+endef
180
+
181
+define Package/iotivity-plugin-manager-lib/install
182
+	$(INSTALL_DIR) $(1)/usr/lib
183
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/out/linux/$(ARCH)/release/libpmimpl.so $(1)/usr/lib/libpmimpl.so
184
+endef
185
+
186
+define Package/iotivity-mqttclient/install
187
+	$(INSTALL_DIR) $(1)/usr/bin
188
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/out/linux/$(ARCH)/release/service/protocol-plugin/sample-app/linux/mqtt/mqttclient $(1)/usr/bin/mqttclient
189
+endef
190
+
191
+define Package/iotivity-oic-middle/install
192
+	$(INSTALL_DIR) $(1)/usr/bin
193
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/out/linux/$(ARCH)/release/examples/OICMiddle/OICMiddle $(1)/usr/bin/OICMiddle
194
+endef
195
+
196
+define Package/iotivity-things-manager/install
197
+	$(INSTALL_DIR) $(1)/usr/bin
198
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/out/linux/$(ARCH)/release/service/things-manager/sampleapp/linux/configuration/bootstrapserver $(1)/usr/bin/bootstrapserver
199
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/out/linux/$(ARCH)/release/service/things-manager/sampleapp/linux/configuration/con-server $(1)/usr/bin/con-server
200
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/out/linux/$(ARCH)/release/service/things-manager/sampleapp/linux/configuration/con-client $(1)/usr/bin/con-client
201
+endef
202
+
203
+define Package/iotivity-example-garage/install
204
+	$(INSTALL_DIR) $(1)/usr/bin
205
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/out/linux/$(ARCH)/release/resource/examples/garageclient $(1)/usr/bin/garageclient
206
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/out/linux/$(ARCH)/release/resource/examples/garageserver $(1)/usr/bin/garageserver
207
+endef
208
+
209
+
210
+$(eval $(call BuildPackage,iotivity))
211
+$(eval $(call BuildPackage,iotivity-things-manager-lib))
212
+$(eval $(call BuildPackage,iotivity-plugin-manager-lib))
213
+$(eval $(call BuildPackage,iotivity-mqttclient))
214
+$(eval $(call BuildPackage,iotivity-oic-middle))
215
+$(eval $(call BuildPackage,iotivity-things-manager))
216
+$(eval $(call BuildPackage,iotivity-example-garage))

+ 11
- 0
net/iotivity/patches/001-no_unit_test.patch Wyświetl plik

@@ -0,0 +1,11 @@
1
+--- a/resource/SConscript
2
++++ b/resource/SConscript
3
+@@ -61,7 +61,7 @@ if target_os == 'linux':
4
+ 	SConscript('csdk/stack/samples/linux/secure/SConscript')
5
+ 
6
+ 	# Build C/C++ unit tests
7
+-	SConscript('unit_tests.scons')
8
++	# SConscript('unit_tests.scons')
9
+ 
10
+ elif target_os == 'darwin':
11
+ 	# Build linux samples for now.

+ 29
- 0
net/iotivity/patches/002-do-not-chck-for-boost.patch Wyświetl plik

@@ -0,0 +1,29 @@
1
+From 51e26e002aa043435f94ac0f071066090d5c2de8 Mon Sep 17 00:00:00 2001
2
+From: Hauke Mehrtens <hauke@hauke-m.de>
3
+Date: Mon, 22 Jun 2015 20:23:36 +0200
4
+Subject: [PATCH 5/5] do not chck for boost
5
+
6
+Boost is not needed for every package just for some.
7
+
8
+Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
9
+---
10
+ service/third_party_libs.scons | 8 --------
11
+ 1 file changed, 8 deletions(-)
12
+
13
+--- a/service/third_party_libs.scons
14
++++ b/service/third_party_libs.scons
15
+@@ -49,14 +49,6 @@ if target_os in ['linux', 'tizen']:
16
+ 
17
+ 		conf = Configure(lib_env)
18
+ 
19
+-		if target_os not in ['tizen'] and not conf.CheckLib('boost_thread', language='C++'):
20
+-			print 'Did not find boost_thread, exiting!'
21
+-			Exit(1)
22
+-
23
+-		if target_os not in ['tizen'] and not conf.CheckLib('boost_system', language='C++'):
24
+-			print 'Did not find boost_system, exiting!'
25
+-			Exit(1)
26
+-
27
+ 		lib_env = conf.Finish()
28
+ 
29
+ ######################################################################

+ 38
- 0
net/iotivity/patches/004-use-env.patch Wyświetl plik

@@ -0,0 +1,38 @@
1
+From 884e831ed07607097614276f6bbf192993228100 Mon Sep 17 00:00:00 2001
2
+From: Hauke Mehrtens <hauke.mehrtens@lantiq.com>
3
+Date: Tue, 2 Jun 2015 11:08:17 +0200
4
+Subject: [PATCH 3/4] 004-use-env.patch
5
+
6
+---
7
+ build_common/SConscript | 22 ++++++++++++++++++++++
8
+ 1 file changed, 22 insertions(+)
9
+
10
+--- a/build_common/SConscript
11
++++ b/build_common/SConscript
12
+@@ -106,6 +106,26 @@ tc_set_msg = '''
13
+ * cause inexplicable errors.                                                  *
14
+ *******************************************************************************
15
+ '''
16
++env['ENV'] = os.environ
17
++if 'CC' in os.environ:
18
++	env['CC'] = Split(os.environ['CC'])
19
++	print "using CC from enviroment: %s" % env['CC']
20
++if 'CXX' in os.environ:
21
++	env['CXX'] = Split(os.environ['CXX'])
22
++	print "using CXX from enviroment: %s" % env['CXX']
23
++if 'CFLAGS' in os.environ:
24
++	env['CFLAGS'] = Split(os.environ['CFLAGS'])
25
++	print "using CFLAGS from enviroment: %s" % env['CFLAGS']
26
++if 'CXXFLAGS' in os.environ:
27
++	env['CXXFLAGS'] = Split(os.environ['CXXFLAGS'])
28
++	print "using CXXFLAGS from enviroment: %s" % env['CXXFLAGS']
29
++if 'CPPFLAGS' in os.environ:
30
++	env['CPPFLAGS'] = Split(os.environ['CPPFLAGS'])
31
++	print "using CPPFLAGS from enviroment: %s" % env['CPPFLAGS']
32
++if 'LDFLAGS' in os.environ:
33
++	env['LINKFLAGS'] = Split(os.environ['LDFLAGS'])
34
++	print "using LDFLAGS/LINKFLAGS from enviroment: %s" % env['LINKFLAGS']
35
++
36
+ if env.get('VERBOSE') == False:
37
+ 	env['CCCOMSTR'] = "Compiling $TARGET"
38
+ 	env['CXXCOMSTR'] = "Compiling $TARGET"

+ 32
- 0
net/iotivity/patches/010-libcoap-fix-big-endian-problems.patch Wyświetl plik

@@ -0,0 +1,32 @@
1
+From 62c0a14ccd333d0e55fc431f151253a72a2836d0 Mon Sep 17 00:00:00 2001
2
+From: Hauke Mehrtens <hauke.mehrtens@lantiq.com>
3
+Date: Mon, 8 Jun 2015 21:57:52 +0200
4
+Subject: [PATCH] libcoap: fix big endian problems
5
+
6
+When this is build for a big endian Linux system WORDS_BIGENDIAN was
7
+not be set. This patch sets it correctly so it will not generate broken
8
+code on big endian systems.
9
+This was tested on MIPS BE 32 Bit.
10
+
11
+Change-Id: I59dd07d8020c553318e2aa43894a2185fe9b9286
12
+Signed-off-by: Hauke Mehrtens <hauke.mehrtens@lantiq.com>
13
+Reviewed-on: https://gerrit.iotivity.org/gerrit/1219
14
+Tested-by: jenkins-iotivity <jenkins-iotivity@opendaylight.org>
15
+Reviewed-by: Erich Keane <erich.keane@intel.com>
16
+---
17
+ resource/csdk/connectivity/lib/libcoap-4.1.1/config.h | 4 ++--
18
+ 1 file changed, 2 insertions(+), 2 deletions(-)
19
+
20
+--- a/resource/csdk/connectivity/lib/libcoap-4.1.1/config.h
21
++++ b/resource/csdk/connectivity/lib/libcoap-4.1.1/config.h
22
+@@ -135,8 +135,8 @@
23
+ #  define WORDS_BIGENDIAN 1
24
+ # endif
25
+ #else
26
+-# ifndef WORDS_BIGENDIAN
27
+-/* #  undef WORDS_BIGENDIAN */
28
++# if defined(__BYTE_ORDER__) && (__BYTE_ORDER__ == __ORDER_BIG_ENDIAN__)
29
++#  define WORDS_BIGENDIAN 1
30
+ # endif
31
+ #endif
32
+ 

+ 35
- 0
net/iotivity/patches/011-cdsk-fix-big-endian-problem.patch Wyświetl plik

@@ -0,0 +1,35 @@
1
+From 7189bc088f558945972d82a9a3427001cb20000a Mon Sep 17 00:00:00 2001
2
+From: Hauke Mehrtens <hauke.mehrtens@lantiq.com>
3
+Date: Mon, 8 Jun 2015 22:03:19 +0200
4
+Subject: [PATCH] cdsk: fix big endian problem
5
+
6
+Without this patch the client will endianes swap the port number when
7
+sending the detailed request after it got the answer for his multicast
8
+get. Use the same method for storing the port number in the address
9
+array in ever part of the code and do not use memcpy and manual
10
+bytewise coping mixed over the code. memcpy was used once and byte wise
11
+copy was used twice so I choose the majority.
12
+This was tested on MIPS BE 32 Bit.
13
+
14
+Change-Id: Ib486171987004d10209d2bbf6b1d9ada75235651
15
+Signed-off-by: Hauke Mehrtens <hauke.mehrtens@lantiq.com>
16
+Reviewed-on: https://gerrit.iotivity.org/gerrit/1220
17
+Tested-by: jenkins-iotivity <jenkins-iotivity@opendaylight.org>
18
+Reviewed-by: Doug Hudson <douglas.hudson@intel.com>
19
+Reviewed-by: Erich Keane <erich.keane@intel.com>
20
+---
21
+ resource/csdk/stack/src/ocstack.c | 3 ++-
22
+ 1 file changed, 2 insertions(+), 1 deletion(-)
23
+
24
+--- a/resource/csdk/stack/src/ocstack.c
25
++++ b/resource/csdk/stack/src/ocstack.c
26
+@@ -723,7 +723,8 @@ OCStackResult UpdateResponseAddr(OCDevAd
27
+         address->addr[i] = atoi(tok);
28
+     }
29
+ 
30
+-    memcpy(&address->addr[4], &endPoint->addressInfo.IP.port, sizeof(uint16_t));
31
++    address->addr[4] = (uint8_t)endPoint->addressInfo.IP.port;
32
++    address->addr[5] = (uint8_t)(endPoint->addressInfo.IP.port >> 8);
33
+     ret = OC_STACK_OK;
34
+ 
35
+ exit:

+ 60
- 0
net/iotivity/patches/020-Do-not-set-architecture-specific-flags.patch Wyświetl plik

@@ -0,0 +1,60 @@
1
+From 980ef34a085f654e74c9896e8143e6f970049b6c Mon Sep 17 00:00:00 2001
2
+From: Hauke Mehrtens <hauke@hauke-m.de>
3
+Date: Mon, 22 Jun 2015 19:39:58 +0200
4
+Subject: [PATCH 3/5] Do not set architecture specific flags
5
+
6
+Setting architecture specific flags causes problems when you want to
7
+build something which is not covered by these.
8
+
9
+Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
10
+---
11
+ build_common/linux/SConscript                     | 20 --------------------
12
+ resource/csdk/connectivity/build/linux/SConscript | 20 --------------------
13
+ 2 files changed, 40 deletions(-)
14
+
15
+--- a/build_common/linux/SConscript
16
++++ b/build_common/linux/SConscript
17
+@@ -24,20 +24,3 @@ env.AppendUnique(LINKFLAGS = ['-ldl', '-
18
+ 
19
+ # Set arch flags
20
+ target_arch = env.get('TARGET_ARCH')
21
+-if target_arch in ['x86']:
22
+-	env.AppendUnique(CCFLAGS = ['-m32'])
23
+-	env.AppendUnique(LINKFLAGS = ['-m32'])
24
+-elif target_arch in ['x86_64']:
25
+-	env.AppendUnique(CCFLAGS = ['-m64'])
26
+-	env.AppendUnique(LINKFLAGS = ['-m64'])
27
+-elif target_arch.find('v7a-hard') > 0:
28
+-	env.AppendUnique(CPPFLAGS = ['-march=armv7-a'])
29
+-	env.AppendUnique(CPPFLAGS = ['-mfloat-abi=hard'])
30
+-	env.AppendUnique(CCFLAGS = ['-mfloat-abi=hard'])
31
+-	env.AppendUnique(LINKFLAGS = ['-mfloat-abi=hard'])
32
+-elif target_arch.find('v7a') > 0:
33
+-	env.AppendUnique(CPPFLAGS = ['-march=armv7-a'])
34
+-elif target_arch.find('arm64') >= 0:
35
+-	env.AppendUnique(CPPFLAGS = ['-march=armv8-a'])
36
+-else:
37
+-	env.AppendUnique(CPPFLAGS = ['-march=armv5te'])
38
+--- a/resource/csdk/connectivity/build/linux/SConscript
39
++++ b/resource/csdk/connectivity/build/linux/SConscript
40
+@@ -22,20 +22,3 @@ env.AppendUnique(LINKFLAGS = ['-ldl', '-
41
+ 
42
+ # Set arch flags
43
+ target_arch = env.get('TARGET_ARCH')
44
+-if target_arch in ['x86']:
45
+-	env.AppendUnique(CCFLAGS = ['-m32'])
46
+-	env.AppendUnique(LINKFLAGS = ['-m32'])
47
+-elif target_arch in ['x86_64']:
48
+-	env.AppendUnique(CCFLAGS = ['-m64'])
49
+-	env.AppendUnique(LINKFLAGS = ['-m64'])
50
+-elif target_arch.find('v7a-hard') > 0:
51
+-	env.AppendUnique(CPPFLAGS = ['-march=armv7-a'])
52
+-	env.AppendUnique(CPPFLAGS = ['-mfloat-abi=hard'])
53
+-	env.AppendUnique(CCFLAGS = ['-mfloat-abi=hard'])
54
+-	env.AppendUnique(LINKFLAGS = ['-mfloat-abi=hard'])
55
+-elif target_arch.find('v7a') > 0:
56
+-	env.AppendUnique(CPPFLAGS = ['-march=armv7-a'])
57
+-elif target_arch.find('arm64') > 0:
58
+-	env.AppendUnique(CPPFLAGS = ['-march=armv8-a'])
59
+-else:
60
+-	env.AppendUnique(CPPFLAGS = ['-march=armv5te'])

+ 35
- 0
net/iotivity/patches/021-add-some-more-architectures.patch Wyświetl plik

@@ -0,0 +1,35 @@
1
+From f78ba209b14908bf2b6197293e1f9e3458ddba8e Mon Sep 17 00:00:00 2001
2
+From: Hauke Mehrtens <hauke@hauke-m.de>
3
+Date: Mon, 22 Jun 2015 19:59:47 +0200
4
+Subject: [PATCH 4/5] add some more architectures
5
+
6
+This does not scale and this check should be removed.
7
+
8
+Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
9
+---
10
+ build_common/SConscript                     | 2 +-
11
+ resource/csdk/connectivity/build/SConscript | 2 +-
12
+ 2 files changed, 2 insertions(+), 2 deletions(-)
13
+
14
+--- a/build_common/SConscript
15
++++ b/build_common/SConscript
16
+@@ -14,7 +14,7 @@ host_target_map = {
17
+ 
18
+ # Map of os and allowed archs (os: allowed archs)
19
+ os_arch_map = {
20
+-		'linux': ['x86', 'x86_64', 'arm', 'arm64'],
21
++		'linux': ['x86', 'x86_64', 'arm', 'arm64', 'mips', 'mipsel', 'mips64', 'mips64el', 'i386', 'powerpc', 'sparc', 'aarch64'],
22
+ 		'tizen': ['x86', 'x86_64', 'arm', 'arm64', 'armeabi-v7a'],
23
+ 		'android': ['x86', 'x86_64', 'armeabi', 'armeabi-v7a', 'armeabi-v7a-hard', 'arm64-v8a'],
24
+ 		'windows': ['x86', 'amd64', 'arm'],
25
+--- a/resource/csdk/connectivity/build/SConscript
26
++++ b/resource/csdk/connectivity/build/SConscript
27
+@@ -14,7 +14,7 @@ host_target_map = {
28
+ 
29
+ # Map of os and allowed archs (os: allowed archs)
30
+ os_arch_map = {
31
+-		'linux': ['x86', 'x86_64', 'arm', 'arm64'],
32
++		'linux': ['x86', 'x86_64', 'arm', 'arm64', 'mips', 'mipsel', 'mips64', 'mips64el', 'i386', 'powerpc', 'sparc', 'aarch64'],
33
+ 		'tizen': ['x86', 'x86_64', 'arm', 'arm64'],
34
+ 		'android': ['x86', 'x86_64', 'armeabi', 'armeabi-v7a', 'armeabi-v7a-hard', 'arm64-v8a'],
35
+ 		'windows': ['x86', 'amd64', 'arm'],

+ 11
- 0
net/iotivity/patches/030-fix-missing-lib.patch Wyświetl plik

@@ -0,0 +1,11 @@
1
+--- a/service/protocol-plugin/sample-app/linux/SConscript
2
++++ b/service/protocol-plugin/sample-app/linux/SConscript
3
+@@ -41,7 +41,7 @@ if target_os not in ['windows', 'winrt']
4
+ 
5
+ sample_env.AppendUnique(LIBS = ['oc', 'oc_logger', 'octbstack',
6
+                                 'connectivity_abstraction', 'coap',
7
+-                                'ppm', 'pmimpl', 'dl'])
8
++                                'ppm', 'boost_system', 'pmimpl', 'dl'])
9
+ 
10
+ if env.get('SECURED') == '1':
11
+     sample_env.AppendUnique(LIBS = ['tinydtls'])

+ 11
- 0
net/iotivity/patches/040-fix-things-manager.patch Wyświetl plik

@@ -0,0 +1,11 @@
1
+--- a/service/things-manager/sampleapp/linux/configuration/SConscript
2
++++ b/service/things-manager/sampleapp/linux/configuration/SConscript
3
+@@ -57,7 +57,7 @@ conserver = linux_sample_env.Program('co
4
+ conclient = linux_sample_env.Program('con-client', 'con-client.cpp')
5
+ bootstrapserver = linux_sample_env.Program('bootstrapserver', 'bootstrapserver.cpp')
6
+ Alias("ConServerApp", conserver)
7
+-Alias("ConCleintApp", conclient)
8
++Alias("ConClientApp", conclient)
9
+ Alias("BootstrapServerApp", bootstrapserver)
10
+ env.AppendTarget('ConServerApp')
11
+ env.AppendTarget('ConClientApp')

+ 14
- 0
net/iotivity/patches/050-fix-OICMidle.patch Wyświetl plik

@@ -0,0 +1,14 @@
1
+--- a/resource/csdk/stack/include/octypes.h
2
++++ b/resource/csdk/stack/include/octypes.h
3
+@@ -35,9 +35,9 @@ extern "C" {
4
+ //Don't want to expose to application layer that lower level stack is using CoAP.
5
+ 
6
+ /// Authority + URI string to prefix well known queries
7
+-#define OC_WELL_KNOWN_QUERY                  "224.0.1.187:5683/oc/core"
8
++#define OC_WELL_KNOWN_QUERY                  "/oc/core"
9
+ #define OC_MULTICAST_DISCOVERY_URI           "/oc/core"
10
+-#define OC_EXPLICIT_DEVICE_DISCOVERY_URI     "224.0.1.187:5683/oc/core/d?rt=core.led"
11
++#define OC_EXPLICIT_DEVICE_DISCOVERY_URI     "/oc/core/d?rt=core.led"
12
+ /// Multicast address and port string to prefix multicast queries
13
+ #define OC_MULTICAST_PREFIX                  "224.0.1.187:5683"
14
+ /// IP Multicast address to use for multicast requests