Browse Source

glib2: fix compilation in my fedora20 mock

see #72

Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com>
Etienne CHAMPETIER 10 years ago
parent
commit
26e00eef1e
1 changed files with 19 additions and 18 deletions
  1. 19
    18
      libs/glib2/Makefile

+ 19
- 18
libs/glib2/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=glib2
11 11
 PKG_VERSION:=2.41.1
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=glib-$(PKG_VERSION).tar.xz
15 15
 PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
@@ -40,23 +40,24 @@ define Package/glib2/description
40 40
   The GLib library of C routines
41 41
 endef
42 42
 
43
-define Build/Configure
44
-	$(call Build/Configure/Default, \
45
-		--enable-shared \
46
-		--enable-static \
47
-		--enable-debug=no \
48
-		--disable-selinux \
49
-        --disable-fam \
50
-        $(if $(ICONV_FULL),--with-libiconv=gnu) \
51
-		, \
52
-		glib_cv_stack_grows=no \
53
-		glib_cv_uscore=no \
54
-		ac_cv_path_GLIB_GENMARSHAL=$(STAGING_DIR_HOST)/bin/glib-genmarshal \
55
-		ac_cv_func_mmap_fixed_mapped=yes \
56
-		ac_cv_func_posix_getpwuid_r=yes \
57
-		ac_cv_func_posix_getgrgid_r=yes \
58
-	);
59
-endef
43
+HOST_CONFIGURE_ARGS += \
44
+	--disable-selinux
45
+
46
+CONFIGURE_ARGS += \
47
+	--enable-shared \
48
+	--enable-static \
49
+	--enable-debug=no \
50
+	--disable-selinux \
51
+	--disable-fam \
52
+	$(if $(ICONV_FULL),--with-libiconv=gnu)
53
+
54
+CONFIGURE_VARS += \
55
+	glib_cv_stack_grows=no \
56
+	glib_cv_uscore=no \
57
+	ac_cv_path_GLIB_GENMARSHAL=$(STAGING_DIR_HOST)/bin/glib-genmarshal \
58
+	ac_cv_func_mmap_fixed_mapped=yes \
59
+	ac_cv_func_posix_getpwuid_r=yes \
60
+	ac_cv_func_posix_getgrgid_r=yes
60 61
 
61 62
 define Build/InstallDev
62 63
 	$(INSTALL_DIR) $(1)/usr/include