Ver código fonte

znc: update to 1.4

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
Jonas Gorski 10 anos atrás
pai
commit
272014632f
2 arquivos alterados com 15 adições e 2 exclusões
  1. 2
    2
      net/znc/Makefile
  2. 13
    0
      net/znc/patches/900-remove_cpp11_usage.patch

+ 2
- 2
net/znc/Makefile Ver arquivo

@@ -8,13 +8,13 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=znc
11
-PKG_VERSION:=1.2
11
+PKG_VERSION:=1.4
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://znc.in/releases \
16 16
 		http://znc.in/releases/archive
17
-PKG_MD5SUM:=ef18e5402a82cc3fcab5c2ac5c2e6f3b
17
+PKG_MD5SUM:=630cb74db34d2d5451ba30b47869f6bb
18 18
 
19 19
 PKG_MAINTAINER:=Jonas Gorski <jogo@openwrt.org>
20 20
 PKG_LICENSE:=Apache-2.0

+ 13
- 0
net/znc/patches/900-remove_cpp11_usage.patch Ver arquivo

@@ -0,0 +1,13 @@
1
+diff --git a/modules/certauth.cpp b/modules/certauth.cpp
2
+index 61e5687..4857d59 100644
3
+--- a/modules/certauth.cpp
4
++++ b/modules/certauth.cpp
5
+@@ -204,7 +204,7 @@ public:
6
+ 			return;
7
+ 		}
8
+ 
9
+-		SCString::const_iterator it2 = it->second.begin();
10
++		SCString::iterator it2 = it->second.begin();
11
+ 		while (id > 1) {
12
+ 			++it2;
13
+ 			id--;