瀏覽代碼

Upgrade socat to 1.7.3.0.

The cross-compiling patch is no longer necessary.  Also added librt as a
dependency, since it is required.  This also fixes an issue where
support for linux/errqueue.h was not being detected correctly and
causing a build failure with 3.18.

Signed-off-by: John Szakmeister <john@szakmeister.net>
John Szakmeister 10 年之前
父節點
當前提交
2720fe57e5
共有 2 個文件被更改,包括 4 次插入26 次删除
  1. 4
    4
      net/socat/Makefile
  2. 0
    22
      net/socat/patches/010-fix_cross_compiling_error.patch

+ 4
- 4
net/socat/Makefile 查看文件

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=socat
11
-PKG_VERSION:=1.7.2.4
12
-PKG_RELEASE:=2
11
+PKG_VERSION:=1.7.3.0
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15 15
 PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download
16
-PKG_MD5SUM:=69b8155dd442a6f24e28ef5407d868eb
16
+PKG_MD5SUM:=b607edb65bc6c57f4a43f06247504274
17 17
 
18 18
 PKG_MAINTAINER:= Ted Hess <thess@kitschensync.net>
19 19
 
@@ -27,7 +27,7 @@ include $(INCLUDE_DIR)/package.mk
27 27
 define Package/socat
28 28
   SECTION:=net
29 29
   CATEGORY:=Network
30
-  DEPENDS:=+libpthread +SOCAT_SSL:libopenssl
30
+  DEPENDS:=+libpthread +librt +SOCAT_SSL:libopenssl
31 31
   TITLE:=A multipurpose relay (SOcket CAT)
32 32
   URL:=http://www.dest-unreach.org/socat/
33 33
 endef

+ 0
- 22
net/socat/patches/010-fix_cross_compiling_error.patch 查看文件

@@ -1,22 +0,0 @@
1
---- a/configure.in
2
-+++ b/configure.in
3
-@@ -41,7 +41,7 @@ AC_CHECK_PROG(AR, ar, ar, gar)
4
- # fail
5
- AC_LANG_COMPILER_REQUIRE()
6
- 
7
--if test "$CC" = "gcc"; then
8
-+if test "$GCC" = yes; then
9
-    CFLAGS="$CFLAGS -D_GNU_SOURCE -Wall -Wno-parentheses"
10
-    ERRONWARN="-Werror -O0"
11
- elif test "$CC" = "clang"; then
12
---- a/configure
13
-+++ b/configure
14
-@@ -3348,7 +3348,7 @@ fi
15
- 
16
- 
17
- 
18
--if test "$CC" = "gcc"; then
19
-+if test "$GCC" = yes; then
20
-    CFLAGS="$CFLAGS -D_GNU_SOURCE -Wall -Wno-parentheses"
21
-    ERRONWARN="-Werror -O0"
22
- elif test "$CC" = "clang"; then