|
@@ -8,12 +8,12 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=bmon
|
11
|
|
-PKG_VERSION:=3.5
|
|
11
|
+PKG_VERSION:=3.8
|
12
|
12
|
PKG_RELEASE:=1
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
15
|
15
|
PKG_SOURCE_URL:=https://github.com/tgraf/bmon/releases/download/v$(PKG_VERSION)/
|
16
|
|
-PKG_MD5SUM:=b7d0d055727f2cf1e452f26dfbf6a825
|
|
16
|
+PKG_MD5SUM:=162ce0d108ff32cbf44b874c5a7e8147
|
17
|
17
|
PKG_MAINTAINER:=Baptiste Jonglez <openwrt-pkg@bitsofnetworks.org>
|
18
|
18
|
PKG_LICENSE:=MIT
|
19
|
19
|
|
|
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
|
22
|
22
|
define Package/bmon
|
23
|
23
|
SECTION:=net
|
24
|
24
|
CATEGORY:=Network
|
25
|
|
- DEPENDS:=+PACKAGE_libncursesw:libncursesw +!PACKAGE_libncursesw:libncurses +libnl +confuse
|
|
25
|
+ DEPENDS:=+PACKAGE_libncursesw:libncursesw +!PACKAGE_libncursesw:libncurses +libnl +confuse +terminfo
|
26
|
26
|
TITLE:=bmon is a portable bandwidth monitor
|
27
|
27
|
URL:=https://github.com/tgraf/bmon/
|
28
|
28
|
endef
|
|
@@ -40,6 +40,9 @@ CONFIGURE_ARGS += \
|
40
|
40
|
CONFIGURE_VARS += \
|
41
|
41
|
ac_cv_lib_nl_nl_connect=no \
|
42
|
42
|
|
|
43
|
+# Needed to compile some objects
|
|
44
|
+TARGET_CFLAGS+= -std=gnu99
|
|
45
|
+
|
43
|
46
|
define Package/bmon/install
|
44
|
47
|
$(INSTALL_DIR) $(1)/usr/sbin
|
45
|
48
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/bmon $(1)/usr/sbin/
|