Explorar el Código

libdmapsharing: make check library optionnal

Signed-off-by: Nicolas Thill <nico@openwrt.org>
Nicolas Thill hace 10 años
padre
commit
27bd80910a
Se han modificado 1 ficheros con 17 adiciones y 0 borrados
  1. 17
    0
      libs/libdmapsharing/patches/003-make_unit_test_optional.patch

+ 17
- 0
libs/libdmapsharing/patches/003-make_unit_test_optional.patch Ver fichero

@@ -0,0 +1,17 @@
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -357,7 +357,13 @@ if test -n "$BUILD_DPAPVIEW" ; then
4
+ 	AC_WARN([will not build dpapview])
5
+ fi
6
+ 
7
+-PKG_CHECK_MODULES([CHECK], [check >= 0.9.4],have_check=yes,have_check=no)
8
++dnl Test if --enable-unit-test given
9
++AC_ARG_ENABLE(unit-test, [AC_HELP_STRING([--enable-unit-test],[enable unit test])])
10
++if test "x$enable_unit_test" = "xyes" ; then
11
++  PKG_CHECK_MODULES([CHECK], [check >= 0.9.4],have_check=yes,have_check=no)
12
++else
13
++  have_check=no
14
++fi
15
+ AM_CONDITIONAL(HAVE_CHECK, test x"$have_check" = "xyes")
16
+ if test "x$have_check" = "xyes"; then
17
+ 	AC_DEFINE(HAVE_CHECK, 1, [Define if check support is enabled])