|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2008-2015 OpenWrt.org
|
|
2
|
+# Copyright (C) 2008-2016 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -9,14 +9,16 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=libesmtp
|
11
|
11
|
PKG_VERSION:=1.0.6
|
12
|
|
-PKG_RELEASE:=2
|
13
|
|
-PKG_MD5SUM:=c4fedc999b6c3820296b0eb92cc2e252
|
|
12
|
+PKG_RELEASE:=3
|
14
|
13
|
|
15
|
14
|
PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
|
16
|
15
|
PKG_LICENSE:=LGPL-2.0+
|
17
|
16
|
PKG_LICENSE_FILES:=COPYING
|
18
|
17
|
|
19
|
|
-PKG_SOURCE_URL:=http://www.stafford.uklinux.net/libesmtp
|
|
18
|
+PKG_SOURCE_PROTO:=git
|
|
19
|
+PKG_SOURCE_URL:=https://github.com/tru7/libesmtp.git
|
|
20
|
+PKG_SOURCE_VERSION=10e9a6df9f76da610941addf71b9a3cbf94f2e9f
|
|
21
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
20
|
22
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
21
|
23
|
|
22
|
24
|
PKG_BUILD_PARALLEL:=1
|
|
@@ -28,13 +30,10 @@ define Package/libesmtp
|
28
|
30
|
SECTION:=libs
|
29
|
31
|
CATEGORY:=Libraries
|
30
|
32
|
TITLE:=A Library for Posting Electronic Mail
|
31
|
|
- URL:=http://www.stafford.uklinux.net/libesmtp/
|
32
|
|
- DEPENDS:=+libpthread
|
|
33
|
+ URL:=https://github.com/tru7/libesmtp.git
|
|
34
|
+ DEPENDS:=+libpthread +libopenssl
|
33
|
35
|
endef
|
34
|
36
|
|
35
|
|
-CONFIGURE_ARGS += \
|
36
|
|
- --without-openssl
|
37
|
|
-
|
38
|
37
|
define Build/InstallDev
|
39
|
38
|
$(INSTALL_DIR) $(1)/usr/bin
|
40
|
39
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libesmtp-config $(1)/usr/bin/
|