Przeglądaj źródła

Add gst1-plugins-ugly package

Signed-off-by: W. Michael Petullo <mike@flyn.org>
W. Michael Petullo 10 lat temu
rodzic
commit
297bf69c4a

+ 136
- 0
multimedia/gst1-plugins-ugly/Makefile Wyświetl plik

@@ -0,0 +1,136 @@
1
+#
2
+# Copyright (C) 2009-2011 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=gst1-plugins-ugly
11
+PKG_VERSION:=1.2.3
12
+PKG_RELEASE:=1
13
+PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
14
+
15
+PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-ugly-$(PKG_VERSION)
16
+PKG_SOURCE:=gst-plugins-ugly-$(PKG_VERSION).tar.xz
17
+PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-ugly/
18
+PKG_MD5SUM:=7ae60e2f759f58f32af5fcdc3c9193c4
19
+
20
+PKG_BUILD_DEPENDS:= gstreamer1 gst1-plugins-base liboil
21
+PKG_CONFIG_DEPENDS:= \
22
+	CONFIG_PACKAGE_gst1-mod-asf \
23
+	CONFIG_PACKAGE_gst1-mod-lame \
24
+	CONFIG_PACKAGE_gst1-mod-mad \
25
+	CONFIG_PACKAGE_gst1-mod-mpeg2dec \
26
+
27
+PKG_FIXUP:=autoreconf
28
+PKG_INSTALL:=1
29
+
30
+include $(INCLUDE_DIR)/package.mk
31
+include $(INCLUDE_DIR)/nls.mk
32
+
33
+define Package/gstreamer1/Default
34
+  CATEGORY:=Multimedia
35
+  SECTION:=multimedia
36
+  TITLE:=GStreamer
37
+  URL:=http://gstreamer.freedesktop.org/
38
+endef
39
+
40
+define Package/gstreamer1/description/Default
41
+ GStreamer open source multimedia framework
42
+endef
43
+
44
+
45
+define Package/gst1-plugins-ugly
46
+$(call Package/gstreamer1/Default)
47
+  TITLE+= plugins collection (ugly)
48
+  DEPENDS+= $(GST_DEPENDS)
49
+endef
50
+
51
+define Package/gts-plugins-ugly/description
52
+$(call Package/gstreamer1/description/Default)
53
+ .
54
+ This meta package contains only dependencies to the other plugins from
55
+ the ugly plugins collection.
56
+endef
57
+
58
+
59
+GST_COND_SELECT = $(patsubst %,$(if $(CONFIG_PACKAGE_gst1-mod-$(1)),--enable,--disable)-%,$(1))
60
+
61
+GST_VERSION:=1.0
62
+
63
+CONFIGURE_ARGS += \
64
+	--disable-debug \
65
+	--disable-examples \
66
+	\
67
+	--disable-a52dec \
68
+	--disable-amrnb \
69
+	--disable-amrwb \
70
+	$(call GST_COND_SELECT,asf) \
71
+	--disable-cdio \
72
+	--disable-dvdlpcmdec \
73
+	--disable-dvdread \
74
+	--disable-dvdsub \
75
+	--disable-iec958 \
76
+	$(call GST_COND_SELECT,lame) \
77
+	$(call GST_COND_SELECT,mad) \
78
+	$(call GST_COND_SELECT,mpeg2dec) \
79
+	--disable-mpegaudioparse \
80
+	--disable-mpegstream \
81
+	--disable-realmedia \
82
+	--disable-sidplay \
83
+	--disable-synaesthesia \
84
+	--disable-twolame \
85
+	--disable-x264 \
86
+	\
87
+	--without-libiconv-prefix \
88
+	--without-libintl-prefix \
89
+
90
+EXTRA_LDFLAGS+= \
91
+	-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
92
+
93
+
94
+define Package/gst1-plugins-ugly/install
95
+	/bin/true
96
+endef
97
+
98
+
99
+# 1: short name
100
+# 2: description
101
+# 3: dependencies on other gstreamer libraries (short name)
102
+# 4: dependencies on other gstreamer plugins (short name)
103
+# 5: dependencies on other packages
104
+define GstBuildPlugin
105
+
106
+  GST_DEPENDS += +gst1-mod-$(1)
107
+
108
+  define Package/gst1-mod-$(1)
109
+    $(call Package/gstreamer1/Default)
110
+    TITLE+= $(2) plugin (ugly)
111
+    DEPENDS+= +libgstreamer1 $$(foreach p,$(3),+libgst1$$(p)) $$(foreach p,$(4),+gst1-mod-$$(p)) $(5)
112
+  endef
113
+
114
+  define Package/gst1-mod-$(1)/description
115
+   $(call Package/gstreamer1/description/Default)
116
+   .
117
+   This package contains the GStreamer $(2) plugin.
118
+  endef
119
+
120
+  define Package/gst1-mod-$(1)/install
121
+	$(INSTALL_DIR) $$(1)/usr/lib/gstreamer-$(GST_VERSION)
122
+	( cd $(PKG_INSTALL_DIR); $(CP) \
123
+		./usr/lib/gstreamer-$(GST_VERSION)/libgst$(1).so* \
124
+		$$(1)/usr/lib/gstreamer-$(GST_VERSION)/ \
125
+	)
126
+  endef
127
+
128
+  $$(eval $$(call BuildPackage,gst1-mod-$(1)))
129
+endef
130
+
131
+$(eval $(call GstBuildPlugin,asf,ASF demuxer,audio riff rtp rtsp sdp tag,,))
132
+$(eval $(call GstBuildPlugin,lame,MP3 encoder (using LAME),audio,,+lame-lib))
133
+$(eval $(call GstBuildPlugin,mad,MP3 decoder (using MAD),audio tag,,+libid3tag +libmad))
134
+$(eval $(call GstBuildPlugin,mpeg2dec,MPEG decoder,video,,+libmpeg2))
135
+
136
+$(eval $(call BuildPackage,gst1-plugins-ugly))

+ 24
- 0
multimedia/gst1-plugins-ugly/patches/001-no_docs.patch Wyświetl plik

@@ -0,0 +1,24 @@
1
+diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.am gst-plugins-ugly-1.0.7/Makefile.am
2
+--- gst-plugins-ugly-1.0.7-vanilla/Makefile.am	2013-06-01 19:58:12.400886469 -0500
3
++++ gst-plugins-ugly-1.0.7/Makefile.am	2013-06-01 19:58:33.306059047 -0500
4
+@@ -1,7 +1,7 @@
5
+ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
6
+ 
7
+ SUBDIRS = \
8
+-	gst-libs gst ext docs m4 tests common pkgconfig po
9
++	gst-libs gst ext m4 tests common pkgconfig po
10
+ 
11
+ # include before EXTRA_DIST for win32 assignment
12
+ include $(top_srcdir)/common/win32.mak
13
+diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.in gst-plugins-ugly-1.0.7/Makefile.in
14
+--- gst-plugins-ugly-1.0.7-vanilla/Makefile.in	2013-06-01 19:58:12.412885994 -0500
15
++++ gst-plugins-ugly-1.0.7/Makefile.in	2013-06-01 19:58:39.810801615 -0500
16
+@@ -453,7 +453,7 @@
17
+ top_srcdir = @top_srcdir@
18
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
19
+ SUBDIRS = \
20
+-	gst-libs gst ext docs m4 tests common pkgconfig po
21
++	gst-libs gst ext m4 tests common pkgconfig po
22
+ 
23
+ 
24
+ # the MANIFEST contains all win32 related files that should be disted

+ 24
- 0
multimedia/gst1-plugins-ugly/patches/002-no_tests.patch Wyświetl plik

@@ -0,0 +1,24 @@
1
+diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.am gst-plugins-ugly-1.0.7/Makefile.am
2
+--- gst-plugins-ugly-1.0.7-vanilla/Makefile.am	2013-06-01 19:59:16.988330482 -0500
3
++++ gst-plugins-ugly-1.0.7/Makefile.am	2013-06-01 19:59:28.455876771 -0500
4
+@@ -1,7 +1,7 @@
5
+ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
6
+ 
7
+ SUBDIRS = \
8
+-	gst-libs gst ext m4 tests common pkgconfig po
9
++	gst-libs gst ext m4 common pkgconfig po
10
+ 
11
+ # include before EXTRA_DIST for win32 assignment
12
+ include $(top_srcdir)/common/win32.mak
13
+diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.in gst-plugins-ugly-1.0.7/Makefile.in
14
+--- gst-plugins-ugly-1.0.7-vanilla/Makefile.in	2013-06-01 19:59:16.988330482 -0500
15
++++ gst-plugins-ugly-1.0.7/Makefile.in	2013-06-01 19:59:39.840426385 -0500
16
+@@ -453,7 +453,7 @@
17
+ top_srcdir = @top_srcdir@
18
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
19
+ SUBDIRS = \
20
+-	gst-libs gst ext m4 tests common pkgconfig po
21
++	gst-libs gst ext m4 common pkgconfig po
22
+ 
23
+ 
24
+ # the MANIFEST contains all win32 related files that should be disted

+ 35
- 0
multimedia/gst1-plugins-ugly/patches/003-no_translations.patch Wyświetl plik

@@ -0,0 +1,35 @@
1
+diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/configure.ac gst-plugins-ugly-1.0.7/configure.ac
2
+--- gst-plugins-ugly-1.0.7-vanilla/configure.ac	2013-06-01 19:59:46.199174835 -0500
3
++++ gst-plugins-ugly-1.0.7/configure.ac	2013-06-01 20:00:29.709453831 -0500
4
+@@ -479,7 +479,6 @@
5
+ tests/Makefile
6
+ tests/check/Makefile
7
+ m4/Makefile
8
+-po/Makefile.in
9
+ pkgconfig/Makefile
10
+ pkgconfig/gstreamer-plugins-ugly-uninstalled.pc
11
+ gst-plugins-ugly.spec
12
+diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.am gst-plugins-ugly-1.0.7/Makefile.am
13
+--- gst-plugins-ugly-1.0.7-vanilla/Makefile.am	2013-06-01 19:59:46.210174399 -0500
14
++++ gst-plugins-ugly-1.0.7/Makefile.am	2013-06-01 20:00:11.351179921 -0500
15
+@@ -1,7 +1,7 @@
16
+ DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
17
+ 
18
+ SUBDIRS = \
19
+-	gst-libs gst ext m4 common pkgconfig po
20
++	gst-libs gst ext m4 common pkgconfig
21
+ 
22
+ # include before EXTRA_DIST for win32 assignment
23
+ include $(top_srcdir)/common/win32.mak
24
+diff -u --recursive gst-plugins-ugly-1.0.7-vanilla/Makefile.in gst-plugins-ugly-1.0.7/Makefile.in
25
+--- gst-plugins-ugly-1.0.7-vanilla/Makefile.in	2013-06-01 19:59:46.210174399 -0500
26
++++ gst-plugins-ugly-1.0.7/Makefile.in	2013-06-01 20:00:20.222829049 -0500
27
+@@ -453,7 +453,7 @@
28
+ top_srcdir = @top_srcdir@
29
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
30
+ SUBDIRS = \
31
+-	gst-libs gst ext m4 common pkgconfig po
32
++	gst-libs gst ext m4 common pkgconfig
33
+ 
34
+ 
35
+ # the MANIFEST contains all win32 related files that should be disted