Browse Source

freeradius2: enable freeradius2-mod-sql-mysql again

compile tested only

Signed-off-by: Etienne CHAMPETIER <champetier.etienne@gmail.com>
Etienne CHAMPETIER 10 years ago
parent
commit
2a2c701917
1 changed files with 9 additions and 9 deletions
  1. 9
    9
      net/freeradius2/Makefile

+ 9
- 9
net/freeradius2/Makefile View File

@@ -424,15 +424,15 @@ else
424 424
   CONFIGURE_ARGS+= --without-rlm_ldap
425 425
 endif
426 426
 
427
-#ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius2-mod-sql-mysql),)
428
-#  CONFIGURE_ARGS+= \
429
-#		--with-mysql-include-dir="$(STAGING_DIR)/usr/include" \
430
-#		--with-mysql-lib-dir="$(STAGING_DIR)/usr/lib/mysql"
431
-#  CONFIGURE_LIBS+= -lz
432
-#  CONFIGURE_VARS+= ac_cv_lib_mysqlclient_r_mysql_init=yes
433
-#else
427
+ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius2-mod-sql-mysql),)
428
+  CONFIGURE_ARGS+= \
429
+		--with-mysql-include-dir="$(STAGING_DIR)/usr/include" \
430
+		--with-mysql-lib-dir="$(STAGING_DIR)/usr/lib/mysql"
431
+  CONFIGURE_LIBS+= -lz
432
+  CONFIGURE_VARS+= ac_cv_lib_mysqlclient_r_mysql_init=yes
433
+else
434 434
   CONFIGURE_ARGS+= --without-rlm_sql_mysql
435
-#endif
435
+endif
436 436
 
437 437
 ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius2-mod-sql-pgsql),)
438 438
   CONFIGURE_ARGS+= \
@@ -618,7 +618,7 @@ $(eval $(call BuildPlugin,freeradius2-mod-pap,rlm_pap,modules/pap,modules,))
618 618
 $(eval $(call BuildPlugin,freeradius2-mod-preprocess,rlm_preprocess,hints huntgroups modules/preprocess,modules,))
619 619
 $(eval $(call BuildPlugin,freeradius2-mod-realm,rlm_realm,proxy.conf modules/realm modules/inner-eap,modules,))
620 620
 $(eval $(call BuildPlugin,freeradius2-mod-sql,rlm_sql,sql.conf,))
621
-#$(eval $(call BuildPlugin,freeradius2-mod-sql-mysql,rlm_sql_mysql,))
621
+$(eval $(call BuildPlugin,freeradius2-mod-sql-mysql,rlm_sql_mysql,))
622 622
 $(eval $(call BuildPlugin,freeradius2-mod-sql-pgsql,rlm_sql_postgresql,))
623 623
 $(eval $(call BuildPlugin,freeradius2-mod-sql-sqlite,rlm_sql_sqlite,))
624 624
 $(eval $(call BuildPlugin,freeradius2-mod-sqlcounter,rlm_sqlcounter,))