Ver código fonte

ocserv: explicitly disable libnl to prevent it from being linked

Signed-off-by: Steven Barth <steven@midlink.org>
Steven Barth 10 anos atrás
pai
commit
2bcd36b0d6
1 arquivos alterados com 2 adições e 1 exclusões
  1. 2
    1
      net/ocserv/Makefile

+ 2
- 1
net/ocserv/Makefile Ver arquivo

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ocserv
11 11
 PKG_VERSION:=0.8.0
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_BUILD_DIR :=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -51,6 +51,7 @@ EXTRA_LDFLAGS+=-lncurses
51 51
 CONFIGURE_ARGS+= \
52 52
 	--enable-local-libopts \
53 53
 	--with-libreadline-prefix="$(STAGING_DIR)/" \
54
+	--without-libnl \
54 55
 
55 56
 ifneq ($(CONFIG_OCSERV_PAM),y)
56 57
 CONFIGURE_ARGS += --without-pam