|
@@ -28,7 +28,7 @@ HOST_BUILD_PARALLEL:=1
|
28
|
28
|
PKG_BUILD_DIR:=$(BUILD_DIR)/Python-$(PKG_VERSION)
|
29
|
29
|
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/Python-$(PKG_VERSION)
|
30
|
30
|
|
31
|
|
-PKG_BUILD_DEPENDS:=python/host
|
|
31
|
+PKG_BUILD_DEPENDS:=libffi/host python/host
|
32
|
32
|
|
33
|
33
|
include $(INCLUDE_DIR)/host-build.mk
|
34
|
34
|
include $(INCLUDE_DIR)/package.mk
|
|
@@ -51,23 +51,23 @@ define Package/python/Default/description
|
51
|
51
|
the development of higher quality, more maintainable code.
|
52
|
52
|
endef
|
53
|
53
|
|
54
|
|
-define Package/python
|
|
54
|
+define Package/python-base
|
55
|
55
|
$(call Package/python/Default)
|
|
56
|
+ TITLE:=Python $(PYTHON_VERSION) interpreter
|
56
|
57
|
DEPENDS:=+libpthread +zlib +libffi +libopenssl
|
57
|
58
|
endef
|
58
|
59
|
|
59
|
|
-define Package/python/description
|
|
60
|
+define Package/python-base/description
|
60
|
61
|
This package contains only the interpreter and the bare minimum
|
61
|
62
|
for the interpreter to start.
|
62
|
63
|
endef
|
63
|
64
|
|
64
|
|
-define Package/python-full
|
|
65
|
+define Package/python
|
65
|
66
|
$(call Package/python/Default)
|
66
|
|
- TITLE:=Full install (minus a few libs)
|
67
|
|
- DEPENDS:=@PACKAGE_python +PACKAGE_python:python +libncursesw
|
|
67
|
+ DEPENDS:=+python-base +libncursesw +libbz2 +libgdbm +libsqlite3 +libexpat +libdb47
|
68
|
68
|
endef
|
69
|
69
|
|
70
|
|
-define Package/python-full/description
|
|
70
|
+define Package/python/description
|
71
|
71
|
This package contains the (almost) full Python install.
|
72
|
72
|
endef
|
73
|
73
|
|
|
@@ -107,10 +107,22 @@ Hooks/Configure/Pre+=\
|
107
|
107
|
|
108
|
108
|
define Build/InstallDev
|
109
|
109
|
$(INSTALL_DIR) $(STAGING_DIR)/mk/
|
|
110
|
+ $(INSTALL_DIR) $(1)/usr/include/ $(1)/usr/lib/
|
|
111
|
+ $(INSTALL_DIR) $(1)/usr/lib/python$(PYTHON_VERSION)/
|
110
|
112
|
$(INSTALL_DATA) ./files/python-package.mk $(STAGING_DIR)/mk/
|
|
113
|
+ $(CP) \
|
|
114
|
+ $(PKG_INSTALL_DIR)/usr/include/python$(PYTHON_VERSION) \
|
|
115
|
+ $(1)/usr/include/
|
|
116
|
+ $(CP) \
|
|
117
|
+ $(STAGING_DIR_HOST)/lib/python$(PYTHON_VERSION) \
|
|
118
|
+ $(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* \
|
|
119
|
+ $(1)/usr/lib/
|
|
120
|
+ $(CP) \
|
|
121
|
+ $(PKG_INSTALL_DIR)/usr/lib/python$(PYTHON_VERSION)/config \
|
|
122
|
+ $(1)/usr/lib/python$(PYTHON_VERSION)/
|
111
|
123
|
endef
|
112
|
124
|
|
113
|
|
-define PyPackage/python/filespec
|
|
125
|
+define PyPackage/python-base/filespec
|
114
|
126
|
+|/usr/bin/python$(PYTHON_VERSION)
|
115
|
127
|
+|/usr/lib/python$(PYTHON_VERSION)/_abcoll.py
|
116
|
128
|
+|/usr/lib/python$(PYTHON_VERSION)/_sysconfigdata.py
|
|
@@ -134,7 +146,7 @@ define PyPackage/python/filespec
|
134
|
146
|
+|/usr/lib/python$(PYTHON_VERSION)/warnings.py
|
135
|
147
|
endef
|
136
|
148
|
|
137
|
|
-define PyPackage/python-full/filespec
|
|
149
|
+define PyPackage/python/filespec
|
138
|
150
|
+|/usr/lib/python$(PYTHON_VERSION)
|
139
|
151
|
-|/usr/lib/python$(PYTHON_VERSION)/config
|
140
|
152
|
-|/usr/lib/python$(PYTHON_VERSION)/distutils
|
|
@@ -147,9 +159,10 @@ define PyPackage/python-full/filespec
|
147
|
159
|
-|/usr/lib/python$(PYTHON_VERSION)/webbrowser.py
|
148
|
160
|
-|/usr/lib/python$(PYTHON_VERSION)/*/test
|
149
|
161
|
-|/usr/lib/python$(PYTHON_VERSION)/*/tests
|
|
162
|
+-|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/readline.so
|
150
|
163
|
endef
|
151
|
164
|
|
152
|
|
-define PyPackage/python/install
|
|
165
|
+define PyPackage/python-base/install
|
153
|
166
|
$(LN) python$(PYTHON_VERSION) $(1)/usr/bin/python
|
154
|
167
|
$(LN) python$(PYTHON_VERSION) $(1)/usr/bin/python2
|
155
|
168
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* $(1)/usr/lib/
|
|
@@ -159,7 +172,9 @@ HOST_CONFIGURE_ARGS+= \
|
159
|
172
|
--without-cxx-main \
|
160
|
173
|
--without-pymalloc \
|
161
|
174
|
--with-threads \
|
162
|
|
- --prefix=$(STAGING_DIR_HOST)
|
|
175
|
+ --prefix=$(STAGING_DIR_HOST) \
|
|
176
|
+ CONFIG_SITE= \
|
|
177
|
+ OPT="$(HOST_CFLAGS)"
|
163
|
178
|
|
164
|
179
|
define Host/Install
|
165
|
180
|
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
|
|
@@ -169,8 +184,8 @@ endef
|
169
|
184
|
|
170
|
185
|
$(eval $(call HostBuild))
|
171
|
186
|
|
|
187
|
+$(eval $(call PyPackage,python-base))
|
172
|
188
|
$(eval $(call PyPackage,python))
|
173
|
|
-$(eval $(call PyPackage,python-full))
|
174
|
189
|
|
|
190
|
+$(eval $(call BuildPackage,python-base))
|
175
|
191
|
$(eval $(call BuildPackage,python))
|
176
|
|
-$(eval $(call BuildPackage,python-full))
|