Browse Source

ibrdtnd: Disable dependency on wifip2p and vmime library

Since the current release of the package does not provide
configure options to disable these dependencies, a patch is necessary.

Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Johannes Morgenroth 10 years ago
parent
commit
2c81073f2f
2 changed files with 76 additions and 1 deletions
  1. 1
    1
      net/ibrdtnd/Makefile
  2. 75
    0
      net/ibrdtnd/patches/100-add_configure_options.patch

+ 1
- 1
net/ibrdtnd/Makefile View File

@@ -37,7 +37,7 @@ define Package/ibrdtnd/description
37 37
 endef
38 38
 
39 39
 CONFIGURE_ARGS += \
40
-        --with-tls --with-sqlite --with-dht
40
+        --with-tls --with-sqlite --with-dht --without-wifip2p --without-vmime
41 41
 
42 42
 define Package/ibrdtnd/install
43 43
 	$(INSTALL_DIR) $(1)/usr/sbin/

+ 75
- 0
net/ibrdtnd/patches/100-add_configure_options.patch View File

@@ -0,0 +1,75 @@
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -333,30 +333,46 @@ AS_IF([test "x$enable_android" = "xyes"], [
4
+ 	dnl optional parameter: Wifi-P2P support
5
+ 	dnl -----------------------------------------------
6
+ 
7
+-	PKG_CHECK_MODULES([WIFIP2P], wifip2p >= 0.1 , [
8
+-				with_wifi_p2p="yes"
9
+-				AC_SUBST(WIFIP2P_CFLAGS)
10
+-				AC_SUBST(WIFIP2P_LIBS)
11
+-				AC_DEFINE(WITH_WIFIP2P, [1], ["wifi-p2p support enabled"])
12
+-			], [
13
+-				with_wifi_p2p="no"
14
+-				AC_MSG_WARN([wifi-p2p library not found. wifi-p2p support is disabled.])
15
+-			])
16
++	AC_ARG_WITH([wifip2p],
17
++		AS_HELP_STRING([--without-wifip2p], [Build without wifip2p support]),
18
++		[
19
++			with_wifi_p2p="no"
20
++			AC_MSG_NOTICE([WIFIP2P support disabled])
21
++		], [
22
++			PKG_CHECK_MODULES([WIFIP2P], wifip2p >= 0.1 , [
23
++						with_wifi_p2p="yes"
24
++						AC_SUBST(WIFIP2P_CFLAGS)
25
++						AC_SUBST(WIFIP2P_LIBS)
26
++						AC_DEFINE(WITH_WIFIP2P, [1], ["wifi-p2p support enabled"])
27
++					], [
28
++						with_wifi_p2p="no"
29
++						AC_MSG_WARN([wifi-p2p library not found. wifi-p2p support is disabled.])
30
++					])
31
++		]
32
++	)
33
+ 
34
+-    dnl -----------------------------------------------
35
+-    dnl optional parameter: VMime support
36
+-    dnl -----------------------------------------------
37
+-
38
+-    PKG_CHECK_MODULES([VMIME], vmime >= 0.9.1 , [
39
+-                with_vmime="yes"
40
+-                AC_SUBST(VMIME_CFLAGS)
41
+-                AC_SUBST(VMIME_LIBS)
42
+-                AC_DEFINE(HAVE_VMIME, [1], ["Email Convergence Layer is available"])
43
+-                AC_CHECK_HEADERS([vmime/utility/smartPtrInt.hpp])
44
+-            ], [
45
+-                with_vmime="no"
46
+-                AC_MSG_WARN([VMime library not found. Email Convergence Layer is disabled.])
47
+-            ])
48
++	dnl -----------------------------------------------
49
++	dnl optional parameter: VMime support
50
++	dnl -----------------------------------------------
51
++
52
++	AC_ARG_WITH([vmime],
53
++		AS_HELP_STRING([--without-vmime], [Build without vmime support]),
54
++		[
55
++			with_vmime="no"
56
++			AC_MSG_NOTICE([VMIME support disabled])
57
++		], [
58
++			PKG_CHECK_MODULES([VMIME], vmime >= 0.9.1 , [
59
++						with_vmime="yes"
60
++						AC_SUBST(VMIME_CFLAGS)
61
++						AC_SUBST(VMIME_LIBS)
62
++						AC_DEFINE(HAVE_VMIME, [1], ["Email Convergence Layer is available"])
63
++						AC_CHECK_HEADERS([vmime/utility/smartPtrInt.hpp])
64
++					], [
65
++						with_vmime="no"
66
++						AC_MSG_WARN([VMime library not found. Email Convergence Layer is disabled.])
67
++					])
68
++		]
69
++	)
70
+ 
71
+ 	dnl -----------------------------------------------
72
+ 	dnl check for regex capabilities
73
+-- 
74
+1.9.1
75
+