|
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=aiccu
|
11
|
11
|
PKG_VERSION:=20070115
|
12
|
|
-PKG_RELEASE:=15
|
|
12
|
+PKG_RELEASE:=16
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
|
15
|
15
|
PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
|
|
@@ -17,28 +17,37 @@ PKG_MD5SUM:=c9bcc83644ed788e22a7c3f3d4021350
|
17
|
17
|
PKG_LICENSE:=BSD-3-Clause
|
18
|
18
|
PKG_LICENSE_FILES:=doc/LICENSE
|
19
|
19
|
|
20
|
|
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
|
|
20
|
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)
|
21
|
21
|
|
22
|
22
|
include $(INCLUDE_DIR)/package.mk
|
23
|
23
|
|
24
|
|
-define Package/aiccu
|
|
24
|
+define Package/aiccu/Default
|
|
25
|
+ TITLE:=SixXS IPv6 Connectivity Client ($(1))
|
25
|
26
|
SECTION:=net
|
26
|
27
|
CATEGORY:=Network
|
27
|
|
- DEPENDS:=+libpthread +ip +kmod-sit +kmod-tun +libgnutls
|
28
|
|
- TITLE:=SixXS Automatic IPv6 Connectivity Client Utility
|
|
28
|
+ VARIANT:=$(2)
|
|
29
|
+ DEPENDS:=+libpthread +ip +kmod-sit +kmod-tun $(3)
|
29
|
30
|
URL:=http://www.sixxs.net/tools/aiccu/
|
30
|
31
|
MAINTAINER:=Ondrej Caletka <ondrej@caletka.cz>
|
31
|
32
|
endef
|
32
|
33
|
|
|
34
|
+Package/aiccu=$(call Package/aiccu/Default,without GNUTLS support,default)
|
|
35
|
+Package/aiccu-gnutls=$(call Package/aiccu/Default,with GNUTLS support,gnutls,+libgnutls)
|
|
36
|
+
|
33
|
37
|
define Build/Configure
|
34
|
38
|
$(SED) "s,strip,/bin/true," $(PKG_BUILD_DIR)/unix-console/Makefile
|
35
|
39
|
endef
|
36
|
40
|
|
|
41
|
+ifeq ($(BUILD_VARIANT),gnutls)
|
|
42
|
+CONFIG_AICCU_GNUTLS:=y
|
|
43
|
+endif
|
|
44
|
+
|
37
|
45
|
define Build/Compile
|
38
|
46
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
39
|
|
- CC="$(TARGET_CC)" OS_NAME="Linux" OS_VERSION="$(LINUX_VERSION)" HAVE_GNUTLS=1 \
|
|
47
|
+ CC="$(TARGET_CC)" OS_NAME="Linux" OS_VERSION="$(LINUX_VERSION)" \
|
40
|
48
|
EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
|
41
|
49
|
EXTRA_LDFLAGS="$(TARGET_LDFLAGS) -pthread" \
|
|
50
|
+ $(if $(CONFIG_AICCU_GNUTLS),HAVE_GNUTLS=1) \
|
42
|
51
|
DEBUG=0
|
43
|
52
|
endef
|
44
|
53
|
|
|
@@ -46,6 +55,8 @@ define Package/aiccu/conffiles
|
46
|
55
|
/etc/config/aiccu
|
47
|
56
|
endef
|
48
|
57
|
|
|
58
|
+Package/aiccu-gnutls/conffiles=$(call Package/aiccu/conffiles)
|
|
59
|
+
|
49
|
60
|
define Package/aiccu/install
|
50
|
61
|
$(INSTALL_DIR) $(1)/usr/sbin $(1)/lib/netifd/proto $(1)/etc/hotplug.d/ntp
|
51
|
62
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(1)/usr/sbin/
|
|
@@ -53,4 +64,7 @@ define Package/aiccu/install
|
53
|
64
|
$(INSTALL_DATA) ./files/aiccu.hotplug $(1)/etc/hotplug.d/ntp/10-aiccu
|
54
|
65
|
endef
|
55
|
66
|
|
|
67
|
+Package/aiccu-gnutls/install=$(call Package/aiccu/install,$(1))
|
|
68
|
+
|
56
|
69
|
$(eval $(call BuildPackage,aiccu))
|
|
70
|
+$(eval $(call BuildPackage,aiccu-gnutls))
|