|
@@ -0,0 +1,42 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=spawn-fcgi
|
|
11
|
+PKG_VERSION:=1.6.4
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
|
15
|
+PKG_SOURCE_URL:=http://download.lighttpd.net/spawn-fcgi/releases-1.6.x/
|
|
16
|
+PKG_MD5SUM:=a67c098a50cd625fd12adf61b5dd4c32
|
|
17
|
+
|
|
18
|
+PKG_LICENSE:=BSD-3c
|
|
19
|
+PKG_LICENSE_FILES:=COPYING
|
|
20
|
+
|
|
21
|
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
|
22
|
+
|
|
23
|
+include $(INCLUDE_DIR)/package.mk
|
|
24
|
+
|
|
25
|
+define Package/spawn-fcgi
|
|
26
|
+ SUBMENU:=Web Servers/Proxies
|
|
27
|
+ SECTION:=net
|
|
28
|
+ CATEGORY:=Network
|
|
29
|
+ TITLE:=Tool to spawn fastcgi applications
|
|
30
|
+ URL:=http://redmine.lighttpd.net/projects/spawn-fcgi
|
|
31
|
+endef
|
|
32
|
+
|
|
33
|
+define Package/spawn-fcgi/description
|
|
34
|
+ spawn-fcgi is used to spawn fastcgi applications
|
|
35
|
+endef
|
|
36
|
+
|
|
37
|
+define Package/spawn-fcgi/install
|
|
38
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
39
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/spawn-fcgi $(1)/usr/bin/
|
|
40
|
+endef
|
|
41
|
+
|
|
42
|
+$(eval $(call BuildPackage,spawn-fcgi))
|