Browse Source

Remove libcrypto dependency

Signed-off-by: Alexander Ryzhov <openwrt@ryzhov-al.ru>
Alexander Ryzhov 9 years ago
parent
commit
2ded312918
4 changed files with 8 additions and 8 deletions
  1. 2
    2
      libs/libimobiledevice/Makefile
  2. 2
    2
      libs/libmicrohttpd/Makefile
  3. 2
    2
      mail/alpine/Makefile
  4. 2
    2
      utils/usbmuxd/Makefile

+ 2
- 2
libs/libimobiledevice/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libimobiledevice
11 11
 PKG_VERSION:=1.2.0
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_MAINTAINER:=Lukasz Baj <l.baj@radytek.com>
15 15
 PKG_LICENSE:=LGPL-2.1+
@@ -42,7 +42,7 @@ define Package/libimobiledevice
42 42
   $(call Package/libimobiledevice/Default)
43 43
   SECTION:=libs
44 44
   CATEGORY:=Libraries
45
-  DEPENDS:=$(ICONV_DEPENDS) +libplist +libusbmuxd +libopenssl +libcrypto
45
+  DEPENDS:=$(ICONV_DEPENDS) +libplist +libusbmuxd +libopenssl
46 46
 endef
47 47
 
48 48
 define Package/libimobiledevice/description

+ 2
- 2
libs/libmicrohttpd/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libmicrohttpd
11 11
 PKG_VERSION:=0.9.38
12
-PKG_RELEASE:=1.1
12
+PKG_RELEASE:=1.2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=@GNU/libmicrohttpd
@@ -29,7 +29,7 @@ define Package/libmicrohttpd
29 29
 	CATEGORY:=Libraries
30 30
 	TITLE:=GNU libmicrohttpd is a library that runs an HTTP server.
31 31
 	URL:=http://www.gnu.org/software/libmicrohttpd/
32
-	DEPENDS:=+libpthread +libgcrypt +libgnutls +libgpg-error +libcrypto +libopenssl
32
+	DEPENDS:=+libpthread +libgcrypt +libgnutls +libgpg-error +libopenssl
33 33
 endef
34 34
 
35 35
 define Package/libmicrohttpd/description

+ 2
- 2
mail/alpine/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=alpine
11 11
 PKG_VERSION:=2.20
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE_URL:=http://patches.freeiz.com/alpine/release/src/
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -44,7 +44,7 @@ endef
44 44
 define Package/alpine
45 45
 $(call Package/alpine/Default)
46 46
   TITLE+= (with OpenSSL support)
47
-  DEPENDS+= +libcrypto +libopenssl
47
+  DEPENDS+= +libopenssl
48 48
   VARIANT:=ssl
49 49
 endef
50 50
 

+ 2
- 2
utils/usbmuxd/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=usbmuxd
11 11
 PKG_VERSION:=1.1.1
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 PKG_SOURCE_PROTO:=git
14 14
 
15 15
 PKG_MAINTAINER:=Lukasz Baj <l.baj@radytek.com>
@@ -31,7 +31,7 @@ define Package/usbmuxd
31 31
   CATEGORY:=Utilities
32 32
   TITLE:=USB multiplexing daemon
33 33
   URL:=http://www.libimobiledevice.org/
34
-  DEPENDS:=+librt +libusb-1.0 +libusbmuxd +libcrypto +libopenssl +libimobiledevice
34
+  DEPENDS:=+librt +libusb-1.0 +libusbmuxd +libopenssl +libimobiledevice
35 35
 endef
36 36
 
37 37
 define Package/usbmuxd/description