瀏覽代碼

gnunet: update source, add iptables dependency

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 9 年之前
父節點
當前提交
2e2299192d
共有 2 個檔案被更改,包括 6 行新增11 行删除
  1. 2
    3
      net/gnunet/Makefile
  2. 4
    8
      net/gnunet/files/gnunet.defaults

+ 2
- 3
net/gnunet/Makefile 查看文件

@@ -8,12 +8,11 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gnunet
11
-PKG_SOURCE_VERSION:=36190
11
+PKG_SOURCE_VERSION:=36242
12 12
 PKG_VERSION:=0.10.1-svn$(PKG_SOURCE_VERSION)
13 13
 PKG_RELEASE:=1
14 14
 
15 15
 # ToDo:
16
-#  - UCI integration
17 16
 #  - break-out {peer,name,data}store for each backend
18 17
 #  - package testing stuff
19 18
 
@@ -237,7 +236,7 @@ LIBEXEC_transport-bluetooth:=helper-transport-bluetooth
237 236
 DEPENDS_utils:=+certtool +openssl-util
238 237
 BIN_utils:=gns-proxy-setup-ca transport-certificate-creation
239 238
 
240
-DEPENDS_vpn:=+kmod-tun
239
+DEPENDS_vpn:=+kmod-tun +iptables
241 240
 BIN_vpn:=vpn
242 241
 LIB_vpn:=tun vpn
243 242
 LIBEXEC_vpn:=daemon-exit daemon-pt helper-exit helper-vpn service-vpn

+ 4
- 8
net/gnunet/files/gnunet.defaults 查看文件

@@ -28,13 +28,9 @@ uci set gnunet.pt.FORCESTART=YES
28 28
 uci set gnunet.exit=gnunet-config
29 29
 uci set gnunet.exit.AUTOSTART=YES
30 30
 uci set gnunet.exit.FORCESTART=YES
31
-uci set gnunet.exit.EXIT_IPV4=YES
32
-uci set gnunet.exit.EXIT_RANGE_IPV4_POLICY="169.254.86.1:7;169.254.86.1:5201;"
33
-
34
-# iperf (TCP) and echo (UDP) for battlemesh
35
-uci set gnunet.iperf=gnunet-exit-service
36
-uci set gnunet.iperf.TCP_REDIRECTS="5201:169.254.86.1:5201"
37
-uci set gnunet.echo=gnunet-exit-service
38
-uci set gnunet.echo.UDP_REDIRECTS="7:169.254.86.1:7"
31
+
32
+# increase WORKDELAY to something more sane on small CPUs
33
+uci set gnunet.nse=gnunet-config
34
+uci set gnunet.nse.WORKDELAY='500 ms'
39 35
 
40 36
 uci commit gnunet