|
@@ -0,0 +1,51 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=python3-bottle
|
|
11
|
+PKG_VERSION:=0.12.8
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_LICENSE:=MIT
|
|
15
|
+PKG_MAINTAINER:=Luka Perkov <luka@openwrt.org>
|
|
16
|
+
|
|
17
|
+PKG_SOURCE:=$(PKG_VERSION).tar.gz
|
|
18
|
+PKG_SOURCE_URL:=https://github.com/bottlepy/bottle/archive
|
|
19
|
+PKG_MD5SUM:=50a6ebada59391e8d01b2bd2ec52f05b
|
|
20
|
+PKG_BUILD_DIR:=$(BUILD_DIR)/bottle-$(PKG_VERSION)
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+$(call include_mk, python3-package.mk)
|
|
24
|
+
|
|
25
|
+define Package/python3-bottle
|
|
26
|
+ SECTION:=lang
|
|
27
|
+ CATEGORY:=Languages
|
|
28
|
+ SUBMENU:=Python
|
|
29
|
+ TITLE:=Bottle is a fast, simple and lightweight WSGI micro web-framework for Python
|
|
30
|
+ URL:=http://bottlepy.org
|
|
31
|
+ DEPENDS:=+python3
|
|
32
|
+endef
|
|
33
|
+
|
|
34
|
+define Package/python3-bottle/description
|
|
35
|
+ Bottle is a fast, simple and lightweight WSGI micro web-framework for Python.
|
|
36
|
+ It is distributed as a single file module and has no dependencies other than the
|
|
37
|
+ Python Standard Library.
|
|
38
|
+endef
|
|
39
|
+
|
|
40
|
+define Build/Configure
|
|
41
|
+endef
|
|
42
|
+
|
|
43
|
+define Build/Compile
|
|
44
|
+endef
|
|
45
|
+
|
|
46
|
+define Package/python3-bottle/install
|
|
47
|
+ $(INSTALL_DIR) $(1)$(PYTHON3_PKG_DIR)
|
|
48
|
+ $(CP) $(PKG_BUILD_DIR)/bottle.py $(1)$(PYTHON3_PKG_DIR)
|
|
49
|
+endef
|
|
50
|
+
|
|
51
|
+$(eval $(call BuildPackage,python3-bottle))
|