Browse Source

ocserv: fix libcrypt location

fix build errors on Arch Linux/Fedora 20

config.log trying to link with /usr/lib/libcrypt.so
/usr/lib/libcrypt.so: undefined reference to `memset@GLIBC_2.2.5'

linkage is AC_LIB_HAVE_LINKFLAGS macro behaviour
see http://marc.info/?l=gnulib-bug&m=1296602629

Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
Dirk Neukirchen 10 years ago
parent
commit
2e723d4019
1 changed files with 2 additions and 1 deletions
  1. 2
    1
      net/ocserv/Makefile

+ 2
- 1
net/ocserv/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ocserv
11 11
 PKG_VERSION:=0.9.2
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_BUILD_DIR :=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -58,6 +58,7 @@ CONFIGURE_ARGS+= \
58 58
 	--enable-local-libopts \
59 59
 	--with-libreadline-prefix="$(STAGING_DIR)/" \
60 60
 	--without-libnl \
61
+	--with-libcrypt-prefix="$(STAGING_DIR)/" \
61 62
 
62 63
 ifneq ($(CONFIG_OCSERV_PAM),y)
63 64
 CONFIGURE_ARGS += --without-pam