Selaa lähdekoodia

gnutls: updated to 3.4.0

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Nikos Mavrogiannopoulos 10 vuotta sitten
vanhempi
commit
3018b32bbe

+ 6
- 7
libs/gnutls/Makefile Näytä tiedosto

@@ -8,13 +8,14 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gnutls
11
-PKG_VERSION:=3.3.14
11
+PKG_VERSION:=3.4.0
12 12
 PKG_RELEASE:=1
13 13
 PKG_USE_MIPS16:=0
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
16
-PKG_SOURCE_URL:=ftp://ftp.gnutls.org/gcrypt/gnutls/v3.3
17
-PKG_MD5SUM:=7f4465f8c564cf9cb8f5cb38b909f7ca
16
+PKG_SOURCE_URL:=ftp://ftp.gnutls.org/gcrypt/gnutls/v3.4
17
+PKG_MD5SUM:=aa015c2666b031044edfb01b01980d84
18
+PKG_FIXUP:=autoreconf
18 19
 PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
19 20
 
20 21
 PKG_INSTALL:=1
@@ -104,6 +105,7 @@ define Package/libgnutls-openssl
104 105
 $(call Package/gnutls/Default)
105 106
   TITLE+= (OpenSSL compat library)
106 107
   DEPENDS+= +libgnutls
108
+  CONFIGURE_ARGS+= --enable-openssl-compatibility
107 109
 endef
108 110
 
109 111
 define Package/libgnutls-openssl/description
@@ -122,7 +124,6 @@ CONFIGURE_ARGS+= \
122 124
 	--enable-local-libopts \
123 125
 	--disable-doc \
124 126
 	--disable-tests \
125
-	--disable-rsa-export \
126 127
 	--with-default-trust-store-dir=/etc/ssl/certs/ \
127 128
 	--disable-crywrap \
128 129
 	--with-librt-prefix="$(STAGING_DIR)/"
@@ -182,14 +183,12 @@ define Build/InstallDev
182 183
 	$(CP) \
183 184
 		$(PKG_INSTALL_DIR)/usr/include/gnutls \
184 185
 		$(1)/usr/include/
185
-	$(CP) \
186
-		$(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-openssl}.{a,so*} \
187
-		$(1)/usr/lib/
188 186
 	$(CP) \
189 187
 		$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls.pc \
190 188
 		$(1)/usr/lib/pkgconfig/
191 189
 endef
192 190
 
191
+
193 192
 define Package/certtool/conffiles
194 193
 /etc/gnutls/certtool.cfg
195 194
 endef

+ 0
- 15
libs/gnutls/patches/001-ai-idn-remove.patch Näytä tiedosto

@@ -1,15 +0,0 @@
1
-diff --git a/src/socket.c b/src/socket.c
2
-index 82c6252..e2feda9 100644
3
---- a/src/socket.c
4
-+++ b/src/socket.c
5
-@@ -241,10 +241,6 @@ socket_open(socket_st * hd, const char *hostname, const char *service,
6
- 	/* get server name */
7
- 	memset(&hints, 0, sizeof(hints));
8
- 
9
--#ifdef AI_IDN
10
--	hints.ai_flags = AI_IDN|AI_IDN_ALLOW_UNASSIGNED;
11
--#endif
12
--
13
- 	hints.ai_socktype = udp ? SOCK_DGRAM : SOCK_STREAM;
14
- 	if ((err = getaddrinfo(hostname, service, &hints, &res))) {
15
- 		fprintf(stderr, "Cannot resolve %s:%s: %s\n", hostname,

+ 84
- 0
libs/gnutls/patches/001-libopts-detection.patch Näytä tiedosto

@@ -0,0 +1,84 @@
1
+diff --git a/configure.ac b/configure.ac
2
+index 7c454cd..185ebb6 100644
3
+--- a/configure.ac
4
++++ b/configure.ac
5
+@@ -64,7 +64,7 @@ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
6
+ ***
7
+ *** autogen not found. Will not link against libopts.
8
+ *** ]])
9
+-    enable_local_libopts=yes
10
++    included_libopts=yes
11
+   fi
12
+ fi
13
+ 
14
+@@ -523,7 +523,7 @@ fi
15
+ 
16
+ AM_CONDITIONAL(ENABLE_TROUSERS, test "$with_tpm" != "no")
17
+ 
18
+-enable_local_libopts=no
19
++included_libopts=no
20
+ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
21
+ 	LIBOPTS_CHECK([src/libopts])
22
+ 	if test "$NEED_LIBOPTS_DIR" = "true";then
23
+@@ -540,15 +540,17 @@ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
24
+ 		if test -z "$missing_baks"; then
25
+ 			AC_SUBST([AUTOGEN], [/bin/true])
26
+ 		fi
27
+-		enable_local_libopts=yes
28
++		included_libopts=yes
29
+ 	fi
30
+ else
31
+ 	# Need to ensure the relevant conditionals get set
32
+ 	gl_STDNORETURN_H
33
+ 	AM_CONDITIONAL([INSTALL_LIBOPTS],[false])
34
+ 	AM_CONDITIONAL([NEED_LIBOPTS], [false])
35
++	included_libopts=yes
36
+ fi
37
+-AM_CONDITIONAL(NEED_LIBOPTS, test "$enable_local_libopts" = "yes")
38
++
39
++AM_CONDITIONAL(NEED_LIBOPTS, test "$included_libopts" = "yes")
40
+ 
41
+ AC_CHECK_TYPE(ssize_t,
42
+   [
43
+@@ -896,7 +898,7 @@ AC_MSG_NOTICE([summary of build options:
44
+   Compiler:             ${CC}
45
+   CFlags:               ${CFLAGS}
46
+   Library types:        Shared=${enable_shared}, Static=${enable_static}
47
+-  Local libopts:        ${enable_local_libopts}
48
++  Local libopts:        ${included_libopts}
49
+   Local libtasn1:       ${included_libtasn1}
50
+   Use nettle-mini:      ${mini_nettle}
51
+ ])
52
+diff --git a/src/Makefile.am b/src/Makefile.am
53
+index 4105ab6..b907249 100644
54
+--- a/src/Makefile.am
55
++++ b/src/Makefile.am
56
+@@ -30,13 +30,6 @@ if ENABLE_CRYWRAP
57
+ SUBDIRS += crywrap
58
+ endif
59
+ 
60
+-if NEED_LIBOPTS
61
+-LIBOPTS = libopts/libopts.la
62
+-SUBDIRS += libopts
63
+-else
64
+-LIBOPTS = $(LIBOPTS_LDADD)
65
+-endif
66
+-
67
+ EXTRA_DIST = args-std.def
68
+ 
69
+ AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
70
+@@ -49,6 +42,14 @@ AM_CPPFLAGS = \
71
+ 	-I$(srcdir)/../extra/includes	\
72
+ 	$(LIBOPTS_CFLAGS)
73
+ 
74
++if NEED_LIBOPTS
75
++LIBOPTS = libopts/libopts.la
76
++SUBDIRS += libopts
77
++AM_CPPFLAGS += -I$(srcdir)/libopts
78
++else
79
++LIBOPTS = $(LIBOPTS_LDADD)
80
++endif
81
++
82
+ bin_PROGRAMS = psktool gnutls-cli-debug certtool
83
+ if ENABLE_SRP
84
+ bin_PROGRAMS += srptool