Kaynağa Gözat

gcc: Get rid of those sed substitutions and use proper ./configure args instead.

Signed-off-by: Christian Beier <dontmind@freeshell.org>
Christian Beier 10 yıl önce
ebeveyn
işleme
304e86ff28
1 değiştirilmiş dosya ile 13 ekleme ve 9 silme
  1. 13
    9
      devel/gcc/Makefile

+ 13
- 9
devel/gcc/Makefile Dosyayı Görüntüle

@@ -24,6 +24,17 @@ PKG_BUILD_PARALLEL:=1
24 24
 include $(INCLUDE_DIR)/package.mk
25 25
 
26 26
 TARGET_LANGUAGES:="c,c++"
27
+BUGURL=https://dev.openwrt.org/
28
+PKGVERSION=OpenWrt GCC $(PKG_VERSION)
29
+
30
+STRIP:=$(STAGING_DIR_HOST)/bin/sstrip
31
+RSTRIP:= \
32
+       NM="$(TARGET_CROSS)nm" \
33
+       STRIP="$(STRIP) --strip-debug" \
34
+       STRIP_KMOD="$(TARGET_CROSS)strip --strip-debug" \
35
+       $(SCRIPT_DIR)/rstrip.sh
36
+
37
+
27 38
 
28 39
 define Package/gcc
29 40
   SECTION:=devel
@@ -37,21 +48,12 @@ define Package/gcc/description
37 48
 	build a native toolchain for compiling on target
38 49
 endef
39 50
 
40
-STRIP:=$(STAGING_DIR_HOST)/bin/sstrip
41
-RSTRIP:= \
42
-	NM="$(TARGET_CROSS)nm" \
43
-	STRIP="$(STRIP) --strip-debug" \
44
-	STRIP_KMOD="$(TARGET_CROSS)strip --strip-debug" \
45
-	$(SCRIPT_DIR)/rstrip.sh
46
-
47 51
 
48 52
 define Build/Prepare
49 53
 	$(PKG_UNPACK)
50 54
 # 	we have to download additional stuff before patching
51 55
 	(cd $(PKG_BUILD_DIR) && ./contrib/download_prerequisites)
52 56
 	$(Build/Patch)
53
-	$(SED) 's,\(version_string.. = "[0-9\.]*\).*\(";\),\1 (OpenWrt-2.0)\2,' $(PKG_BUILD_DIR)/gcc/version.c
54
-	$(SED) 's,\(bug_report_url.. = "\).*\(";\),\1<URL:https://dev.openwrt.org/>\2,' $(PKG_BUILD_DIR)/gcc/version.c
55 57
 endef
56 58
 
57 59
 
@@ -65,6 +67,8 @@ define Build/Configure
65 67
 			--host=$(REAL_GNU_TARGET_NAME) \
66 68
 			--target=$(REAL_GNU_TARGET_NAME) \
67 69
 			--enable-languages=$(TARGET_LANGUAGES) \
70
+			--with-bugurl=$(BUGURL) \
71
+			--with-pkgversion="$(PKGVERSION)" \
68 72
 			--enable-shared \
69 73
 			--disable-__cxa_atexit \
70 74
 			--enable-target-optspace \