|
@@ -9,20 +9,23 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=pycparser
|
11
|
11
|
PKG_VERSION:=2.14
|
12
|
|
-PKG_RELEASE:=1
|
|
12
|
+PKG_RELEASE:=2
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
15
|
15
|
PKG_SOURCE_URL:=https://pypi.python.org/packages/source/p/pycparser
|
16
|
16
|
PKG_MD5SUM:=a2bc8d28c923b4fe2b2c3b4b51a4f935
|
17
|
17
|
|
18
|
18
|
PKG_BUILD_DEPENDS:=python python-setuptools
|
|
19
|
+HOST_BUILD_DEPENDS:=python/host python-setuptools/host python-ply/host
|
19
|
20
|
|
20
|
21
|
PKG_LICENSE:=BSD-3-Clause
|
21
|
22
|
PKG_LICENSE_FILES:=LICENSE
|
22
|
23
|
PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
|
23
|
24
|
|
|
25
|
+include $(INCLUDE_DIR)/host-build.mk
|
24
|
26
|
include $(INCLUDE_DIR)/package.mk
|
25
|
27
|
$(call include_mk, python-package.mk)
|
|
28
|
+$(call include_mk, python-host.mk)
|
26
|
29
|
|
27
|
30
|
define Package/python-pycparser
|
28
|
31
|
SECTION:=lang
|
|
@@ -39,14 +42,18 @@ module designed to be easily integrated into applications that need to parse
|
39
|
42
|
C source code.
|
40
|
43
|
endef
|
41
|
44
|
|
42
|
|
-define PyPackage/python-pycparser/filespec
|
43
|
|
-+|$(PYTHON_PKG_DIR)
|
44
|
|
--|$(PYTHON_PKG_DIR)/pycparser/ply
|
|
45
|
+define Build/Compile
|
|
46
|
+ $(call Build/Compile/PyMod,,install --prefix="/usr" --root="$(PKG_INSTALL_DIR)")
|
45
|
47
|
endef
|
46
|
48
|
|
47
|
|
-define Build/Compile
|
48
|
|
- $(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
|
|
49
|
+define Host/Compile
|
|
50
|
+ $(call Build/Compile/HostPyMod,,install --prefix="" --root="$(STAGING_DIR_HOST)")
|
49
|
51
|
endef
|
50
|
52
|
|
|
53
|
+define Host/Install
|
|
54
|
+endef
|
|
55
|
+
|
|
56
|
+$(eval $(call HostBuild))
|
|
57
|
+
|
51
|
58
|
$(eval $(call PyPackage,python-pycparser))
|
52
|
59
|
$(eval $(call BuildPackage,python-pycparser))
|