|
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=knot
|
11
|
11
|
PKG_VERSION:=1.5.3
|
12
|
|
-PKG_RELEASE:=1
|
|
12
|
+PKG_RELEASE:=2
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
15
|
15
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
@@ -46,9 +46,27 @@ define Package/knot
|
46
|
46
|
DEPENDS+=+knot-libknot
|
47
|
47
|
endef
|
48
|
48
|
|
49
|
|
-define Package/knot-utils
|
|
49
|
+define Package/knot-dig
|
50
|
50
|
$(call Package/knot/Default)
|
51
|
|
- TITLE+= (utils)
|
|
51
|
+ TITLE+= lookup utility
|
|
52
|
+ DEPENDS+=+knot-libknot
|
|
53
|
+endef
|
|
54
|
+
|
|
55
|
+define Package/knot-host
|
|
56
|
+ $(call Package/knot/Default)
|
|
57
|
+ TITLE+= simple DNS lookup utility
|
|
58
|
+ DEPENDS+=+knot-libknot
|
|
59
|
+endef
|
|
60
|
+
|
|
61
|
+define Package/knot-nsec3hash
|
|
62
|
+ $(call Package/knot/Default)
|
|
63
|
+ TITLE+= simple NSEC3 hash utility
|
|
64
|
+ DEPENDS+=+knot-libknot
|
|
65
|
+endef
|
|
66
|
+
|
|
67
|
+define Package/knot-nsupdate
|
|
68
|
+ $(call Package/knot/Default)
|
|
69
|
+ TITLE+= dynamic DNS update utility
|
52
|
70
|
DEPENDS+=+knot-libknot
|
53
|
71
|
endef
|
54
|
72
|
|
|
@@ -66,8 +84,20 @@ define Package/knot/description
|
66
|
84
|
High-performance authoritative-only DNS server.
|
67
|
85
|
endef
|
68
|
86
|
|
69
|
|
-define Package/knot-utils/description
|
70
|
|
- DNS utilities: kdig, khost, knsupdate and knsec3hash.
|
|
87
|
+define Package/knot-dig/description
|
|
88
|
+ Knot DNS lookup utility.
|
|
89
|
+endef
|
|
90
|
+
|
|
91
|
+define Package/knot-host/description
|
|
92
|
+ Knot DNS simple DNS lookup utility.
|
|
93
|
+endef
|
|
94
|
+
|
|
95
|
+define Package/knot-nsec3hash/description
|
|
96
|
+ Knot DNS simple utility to compute NSEC3 hash.
|
|
97
|
+endef
|
|
98
|
+
|
|
99
|
+define Package/knot-nsupdate/description
|
|
100
|
+ Knot DNS dynamic DNS update utility.
|
71
|
101
|
endef
|
72
|
102
|
|
73
|
103
|
define Package/knot-tests/description
|
|
@@ -114,14 +144,26 @@ define Package/knot/install
|
114
|
144
|
$(INSTALL_BIN) ./files/knotd.init $(1)/etc/init.d/knotd
|
115
|
145
|
endef
|
116
|
146
|
|
117
|
|
-define Package/knot-utils/install
|
|
147
|
+define Package/knot-dig/install
|
118
|
148
|
$(INSTALL_DIR) $(1)/usr/bin
|
119
|
149
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/kdig $(1)/usr/bin/
|
|
150
|
+endef
|
|
151
|
+
|
|
152
|
+define Package/knot-host/install
|
|
153
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
120
|
154
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/khost $(1)/usr/bin/
|
121
|
|
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/knsupdate $(1)/usr/bin/
|
|
155
|
+endef
|
|
156
|
+
|
|
157
|
+define Package/knot-nsec3hash/install
|
|
158
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
122
|
159
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/knsec3hash $(1)/usr/bin/
|
123
|
160
|
endef
|
124
|
161
|
|
|
162
|
+define Package/knot-nsupdate/install
|
|
163
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
164
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/knsupdate $(1)/usr/bin/
|
|
165
|
+endef
|
|
166
|
+
|
125
|
167
|
define Package/knot-tests/install
|
126
|
168
|
$(INSTALL_DIR) $(1)/usr/share/knot
|
127
|
169
|
$(INSTALL_BIN) ./files/runtests.sh $(1)/usr/share/knot/
|
|
@@ -146,5 +188,8 @@ endef
|
146
|
188
|
|
147
|
189
|
$(eval $(call BuildPackage,knot-libknot))
|
148
|
190
|
$(eval $(call BuildPackage,knot))
|
149
|
|
-$(eval $(call BuildPackage,knot-utils))
|
|
191
|
+$(eval $(call BuildPackage,knot-dig))
|
|
192
|
+$(eval $(call BuildPackage,knot-host))
|
|
193
|
+$(eval $(call BuildPackage,knot-nsec3hash))
|
|
194
|
+$(eval $(call BuildPackage,knot-nsupdate))
|
150
|
195
|
$(eval $(call BuildPackage,knot-tests))
|