|
@@ -0,0 +1,54 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2007-2014 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=nano
|
|
11
|
+PKG_VERSION:=2.3.4
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
15
|
+PKG_SOURCE_URL:=http://www.nano-editor.org/dist/v2.3
|
|
16
|
+PKG_MD5SUM:=9cd0a974c7edfdf0f4cb92d1f79d6510
|
|
17
|
+
|
|
18
|
+PKG_INSTALL:=1
|
|
19
|
+PKG_BUILD_PARALLEL:=1
|
|
20
|
+
|
|
21
|
+include $(INCLUDE_DIR)/package.mk
|
|
22
|
+
|
|
23
|
+define Package/nano
|
|
24
|
+ SUBMENU:=Editors
|
|
25
|
+ SECTION:=utils
|
|
26
|
+ CATEGORY:=Utilities
|
|
27
|
+ TITLE:=An enhanced clone of the Pico text editor
|
|
28
|
+ URL:=http://www.nano-editor.org/
|
|
29
|
+ MAINTAINER:=Jonathan Bennett <JBennett@incomsystems.biz>
|
|
30
|
+ DEPENDS:=+libncurses
|
|
31
|
+endef
|
|
32
|
+
|
|
33
|
+define Package/nano/description
|
|
34
|
+ GNU nano (Nano's ANOther editor, or Not ANOther editor) is an enhanced clone
|
|
35
|
+ of the Pico text editor.
|
|
36
|
+endef
|
|
37
|
+
|
|
38
|
+CONFIGURE_ARGS += \
|
|
39
|
+ --enable-tiny \
|
|
40
|
+ --disable-glibtest \
|
|
41
|
+ --disable-utf8 \
|
|
42
|
+ --without-slang \
|
|
43
|
+ --disable-color \
|
|
44
|
+
|
|
45
|
+CONFIGURE_VARS += \
|
|
46
|
+ ac_cv_header_regex_h=no \
|
|
47
|
+
|
|
48
|
+define Package/nano/install
|
|
49
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
50
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/$(PKG_NAME) $(1)/usr/bin/
|
|
51
|
+endef
|
|
52
|
+
|
|
53
|
+$(eval $(call BuildPackage,nano))
|
|
54
|
+
|