Browse Source

libtorrent: update to latest git HEAD

Signed-off-by: Peter Wagner <tripolar@gmx.at>
Peter Wagner 10 years ago
parent
commit
3427303eee
2 changed files with 7 additions and 6 deletions
  1. 5
    4
      libs/libtorrent/Makefile
  2. 2
    2
      libs/libtorrent/patches/100-fix_cross_compile.patch

+ 5
- 4
libs/libtorrent/Makefile View File

@@ -8,13 +8,13 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libtorrent
11
-PKG_VERSION:=0.13.4-git
12
-PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
11
+PKG_VERSION:=0.13.4-git-0
12
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
13 13
 
14 14
 PKG_SOURCE_PROTO:=git
15 15
 PKG_SOURCE_URL:=https://github.com/rakshasa/libtorrent.git
16 16
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
17
-PKG_SOURCE_VERSION:=51cd5ea8913a5f5062813d9f5b6256c76d41ea11
17
+PKG_SOURCE_VERSION:=72e908707f01ee01a9b4918436c64348878b63f7
18 18
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
19 19
 
20 20
 PKG_FIXUP:=autoreconf
@@ -48,7 +48,8 @@ CONFIGURE_ARGS+= \
48 48
 	--enable-aligned \
49 49
 	--disable-debug \
50 50
 	--enable-openssl \
51
-	--disable-instrumentation
51
+	--disable-instrumentation \
52
+	--with-zlib=$(STAGING_DIR)/usr
52 53
 
53 54
 define Build/Configure
54 55
 	( cd $(PKG_BUILD_DIR); ./autogen.sh );

+ 2
- 2
libs/libtorrent/patches/100-fix_cross_compile.patch View File

@@ -21,7 +21,7 @@
21 21
        #include <unistd.h>
22 22
 --- a/scripts/common.m4
23 23
 +++ b/scripts/common.m4
24
-@@ -223,7 +223,7 @@ dnl   Need to fix this so that it uses t
24
+@@ -153,7 +153,7 @@ dnl   Need to fix this so that it uses t
25 25
  AC_DEFUN([TORRENT_CHECK_EXECINFO], [
26 26
    AC_MSG_CHECKING(for execinfo.h)
27 27
  
@@ -30,7 +30,7 @@
30 30
        #include <execinfo.h>
31 31
        int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
32 32
        ])],
33
-@@ -238,7 +238,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
33
+@@ -168,7 +168,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
34 34
  AC_DEFUN([TORRENT_CHECK_ALIGNED], [
35 35
    AC_MSG_CHECKING(the byte alignment)
36 36