|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2008-2015 OpenWrt.org
|
|
2
|
+# Copyright (C) 2008-2016 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -8,18 +8,24 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=linknx
|
11
|
|
-PKG_VERSION:=0.0.1.32
|
12
|
|
-PKG_RELEASE:=7
|
13
|
|
-PKG_MD5SUM:=7ecc1208f59bceb05068c752b2250b63
|
|
11
|
+PKG_VERSION:=0.0.1.33
|
|
12
|
+PKG_RELEASE:=1
|
14
|
13
|
|
15
|
14
|
PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
|
16
|
15
|
PKG_LICENSE:=GPL-2.0+
|
17
|
16
|
|
18
|
|
-PKG_SOURCE_URL:=@SF/linknx
|
19
|
|
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
17
|
+PKG_SOURCE_PROTO:=git
|
|
18
|
+PKG_SOURCE_URL:=https://github.com/linknx/linknx.git
|
|
19
|
+PKG_SOURCE_VERSION:=f627ed44feaea5a1f67c53f2810c44a14c059cef
|
|
20
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)
|
|
21
|
+PKG_SOURCE:=$(PKG_NAME)-${PKG_VERSION}.tar.gz
|
|
22
|
+
|
|
23
|
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
|
20
|
24
|
PKG_BUILD_DEPENDS:=argp-standalone
|
21
|
25
|
PKG_FORTIFY_SOURCE:=1
|
22
|
26
|
|
|
27
|
+PKG_FIXUP:=autoreconf
|
|
28
|
+
|
23
|
29
|
include $(INCLUDE_DIR)/package.mk
|
24
|
30
|
|
25
|
31
|
define Package/linknx
|