Pārlūkot izejas kodu

linknx: bump to new version on new repo

Signed-off-by: Othmar Truniger <github@truniger.ch>
Othmar Truniger 8 gadus atpakaļ
vecāks
revīzija
3448cd9385

+ 12
- 6
net/linknx/Makefile Parādīt failu

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2008-2015 OpenWrt.org
2
+# Copyright (C) 2008-2016 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,18 +8,24 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=linknx
11
-PKG_VERSION:=0.0.1.32
12
-PKG_RELEASE:=7
13
-PKG_MD5SUM:=7ecc1208f59bceb05068c752b2250b63
11
+PKG_VERSION:=0.0.1.33
12
+PKG_RELEASE:=1
14 13
 
15 14
 PKG_MAINTAINER:=Othmar Truniger <github@truniger.ch>
16 15
 PKG_LICENSE:=GPL-2.0+
17 16
 
18
-PKG_SOURCE_URL:=@SF/linknx
19
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
17
+PKG_SOURCE_PROTO:=git
18
+PKG_SOURCE_URL:=https://github.com/linknx/linknx.git
19
+PKG_SOURCE_VERSION:=f627ed44feaea5a1f67c53f2810c44a14c059cef
20
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)
21
+PKG_SOURCE:=$(PKG_NAME)-${PKG_VERSION}.tar.gz
22
+
23
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
20 24
 PKG_BUILD_DEPENDS:=argp-standalone
21 25
 PKG_FORTIFY_SOURCE:=1
22 26
 
27
+PKG_FIXUP:=autoreconf
28
+
23 29
 include $(INCLUDE_DIR)/package.mk
24 30
 
25 31
 define Package/linknx

+ 0
- 10
net/linknx/patches/010-musl-compat Parādīt failu

@@ -1,10 +0,0 @@
1
---- a/src/eibclient.c	2007-10-11 01:55:31.000000000 +0200
2
-+++ b/src/eibclient.c	2015-06-27 22:18:01.433296921 +0200
3
-@@ -32,6 +32,7 @@
4
- #include <netinet/in.h>
5
- #include <netdb.h>
6
- #include <errno.h>
7
-+#include <string.h>
8
- 
9
- #include "config.h"
10
- 

+ 0
- 11
net/linknx/patches/012-fix-linknx.cpp Parādīt failu

@@ -1,11 +0,0 @@
1
---- a/src/linknx.cpp	2012-06-04 22:12:13.000000000 +0200
2
-+++ b/src/linknx.cpp	2015-06-27 22:35:23.705721355 +0200
3
-@@ -136,7 +136,7 @@
4
-     if (errno)
5
-         printf (": %s\n", strerror (errno));
6
-     else
7
--        printf ("\n", strerror (errno));
8
-+        printf ("\n");
9
-     exit (1);
10
- }
11
-