Pārlūkot izejas kodu

luasocket: add socket.unix module

Previous build was missing module socket.unix that is required for
interaction with Unix domain sockets and is distributed in a separate
shared library. This commit adds the file to the created package.

Signed-off-by: Jan Čermák <jan.cermak@nic.cz>
Jan Čermák 10 gadus atpakaļ
vecāks
revīzija
34b21dc910
1 mainītis faili ar 2 papildinājumiem un 1 dzēšanām
  1. 2
    1
      lang/luasocket/Makefile

+ 2
- 1
lang/luasocket/Makefile Parādīt failu

@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
10 10
 PKG_NAME:=luasocket
11 11
 PKG_SOURCE_VERSION:=6d5e40c324c84d9c1453ae88e0ad5bdd0a631448
12 12
 PKG_VERSION:=3.0-rc1-20130909
13
-PKG_RELEASE:=2
13
+PKG_RELEASE:=3
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
16 16
 PKG_SOURCE_URL:=https://github.com/diegonehab/luasocket.git
@@ -56,6 +56,7 @@ define Package/luasocket/install
56 56
 	ln -sf ../mime.so.1.0.3 $(1)/usr/lib/lua/mime/core.so
57 57
 	$(INSTALL_DIR) $(1)/usr/lib/lua/socket
58 58
 	$(INSTALL_DATA) $(PKG_BUILD_DIR)/src/{ftp,http,smtp,tp,url,headers}.lua $(1)/usr/lib/lua/socket
59
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/unix.so $(1)/usr/lib/lua/socket
59 60
 	ln -sf ../socket.so.3.0-rc1 $(1)/usr/lib/lua/socket/core.so
60 61
 endef
61 62