Browse Source

coova-chilli: move to github

Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
Imre Kaloz 10 years ago
parent
commit
34b96ab26e

+ 48
- 0
net/coova-chilli/Config.in View File

@@ -0,0 +1,48 @@
1
+# CoovaChilli avanced configuration
2
+
3
+menu "Configuration"
4
+	depends on PACKAGE_coova-chilli
5
+
6
+config COOVACHILLI_REDIR
7
+	bool "Enable support for redir server. Required for uamregex"
8
+	default n
9
+
10
+config COOVACHILLI_MINIPORTAL
11
+	bool "Enable support Coova miniportal"
12
+	default n
13
+
14
+config COOVACHILLI_USERAGENT
15
+	bool "Enable recording user-agent"
16
+	default n
17
+
18
+config COOVACHILLI_DNSLOG
19
+	bool "Enable support to log DNS name queries"
20
+	default n
21
+
22
+config COOVACHILLI_UAMDOMAINFILE
23
+	bool "Enable loading of mass uamdomains from file"
24
+	default n
25
+
26
+config COOVACHILLI_LARGELIMITS
27
+	bool "Enable larger limits for use with non-embedded systems"
28
+	default n
29
+
30
+choice
31
+	prompt "SSL library"
32
+	default COOVACHILLI_NOSSL
33
+
34
+config COOVACHILLI_NOSSL
35
+	bool "No SSL support"
36
+
37
+config COOVACHILLI_MATRIXSSL
38
+	bool "MatrixSSL"
39
+
40
+config COOVACHILLI_CYASSL
41
+	bool "CyaSSL"
42
+
43
+config COOVACHILLI_OPENSSL
44
+	bool "OpenSSL"
45
+
46
+endchoice
47
+
48
+endmenu

+ 104
- 0
net/coova-chilli/Makefile View File

@@ -0,0 +1,104 @@
1
+#
2
+# Copyright (C) 2007-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=coova-chilli
11
+PKG_VERSION:=1.3.0+20141128
12
+PKG_MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
13
+PKG_LICENSE:=GPL-2.0+
14
+PKG_LICENSE_FILE:=COPYING
15
+PKG_RELEASE:=1
16
+
17
+PKG_SOURCE_PROTO:=git
18
+PKG_SOURCE_URL:=git://github.com/coova/coova-chilli
19
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
20
+PKG_SOURCE_VERSION:=b93de20a288c01c2ba28e96e31ad6da01627f45f
21
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
22
+PKG_MD5SUM:=2adb27ec56172b18c5beee359dd7898d
23
+
24
+PKG_INSTALL:=1
25
+
26
+PKG_CONFIG_DEPENDS := \
27
+  COOVACHILLI_MINIPORTAL \
28
+  COOVACHILLI_REDIR \
29
+  COOVACHILLI_USERAGENT \
30
+  COOVACHILLI_DNSLOG \
31
+  COOVACHILLI_UAMDOMAINFILE \
32
+  COOVACHILLI_LARGELIMITS \
33
+  COOVACHILLI_NOSSL \
34
+  COOVACHILLI_MATRIXSSL \
35
+  COOVACHILLI_CYASSL \
36
+  COOVACHILLI_OPENSSL
37
+
38
+include $(INCLUDE_DIR)/package.mk
39
+
40
+define Package/coova-chilli
41
+  SUBMENU:=Captive Portals
42
+  SECTION:=net
43
+  CATEGORY:=Network
44
+  DEPENDS:=+kmod-tun +librt +COOVACHILLI_MATRIXSSL:libmatrixssl +COOVACHILLI_CYASSL:libcyassl +COOVACHILLI_OPENSSL:libopenssl
45
+  TITLE:=Wireless LAN HotSpot controller (Coova Chilli Version)
46
+  URL:=http://www.coova.org/CoovaChilli
47
+  MENU:=1
48
+endef
49
+
50
+define Package/coova-chilli/description
51
+	CoovaChilli is an open source access controller for wireless LAN
52
+	access points and is based on ChilliSpot. It is used for authenticating
53
+	users of a wireless (or wired) LAN. It supports web based login (UAM)
54
+	which is today's standard for public HotSpots and it supports Wireless
55
+	Protected Access (WPA) which is the standard of the future.
56
+	Authentication,	authorization and accounting (AAA) is handled by your
57
+	favorite radius server.
58
+endef
59
+
60
+define Package/coova-chilli/config
61
+  source "$(SOURCE)/Config.in"
62
+endef
63
+
64
+define Build/Prepare
65
+$(call Build/Prepare/Default)
66
+	( cd $(PKG_BUILD_DIR) ; \
67
+		[ -f ./configure ] || { \
68
+			./bootstrap ; \
69
+		} \
70
+	)
71
+endef
72
+
73
+define Build/Configure
74
+	$(call Build/Configure/Default, \
75
+	$(if $(CONFIG_COOVACHILLI_REDIR),--enable,--disable)-chilliredir \
76
+	$(if $(CONFIG_COOVACHILLI_DNSLOG),--enable,--disable)-dnslog \
77
+	$(if $(CONFIG_COOVACHILLI_MINIPORTAL),--enable,--disable)-miniportal \
78
+	$(if $(CONFIG_COOVACHILLI_USERAGENT),--enable,--disable)-useragent \
79
+	$(if $(CONFIG_COOVACHILLI_LARGELIMITS),--enable,--disable)-largelimits \
80
+	$(if $(CONFIG_COOVACHILLI_UAMDOMAINFILE),--enable,--disable)-uamdomainfile \
81
+	$(if $(CONFIG_COOVACHILLI_MATRIXSSL),--with,--without)-matrixssl \
82
+	$(if $(CONFIG_COOVACHILLI_CYASSL),--with,--without)-cyaxssl \
83
+	$(if $(CONFIG_COOVACHILLI_OPENSSL),--with,--without)-openssl \
84
+	)
85
+endef
86
+
87
+define Package/coova-chilli/conffiles
88
+/etc/chilli.conf
89
+endef
90
+
91
+define Package/coova-chilli/install
92
+	$(INSTALL_DIR) $(1)/etc
93
+	$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/chilli.conf $(1)/etc/
94
+	$(INSTALL_DIR) $(1)/etc/chilli
95
+	$(CP) $(PKG_INSTALL_DIR)/etc/chilli/* $(1)/etc/chilli/
96
+	$(INSTALL_DIR) $(1)/etc/hotplug.d/iface
97
+	$(INSTALL_DATA) ./files/chilli.hotplug $(1)/etc/hotplug.d/iface/30-chilli
98
+	$(INSTALL_DIR) $(1)/usr/sbin
99
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/chilli* $(1)/usr/sbin/
100
+	$(INSTALL_DIR) $(1)/usr/lib/
101
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*.so.* $(1)/usr/lib/
102
+endef
103
+
104
+$(eval $(call BuildPackage,coova-chilli))

+ 7
- 0
net/coova-chilli/files/chilli.hotplug View File

@@ -0,0 +1,7 @@
1
+#!/bin/sh
2
+
3
+[ "$ACTION" == "ifup" ] || exit 0
4
+
5
+[ "$INTERFACE" = "wan" ] && {
6
+	/etc/init.d/chilli restart
7
+}

+ 24
- 0
net/coova-chilli/patches/100-fix-sysinfo-redeclaration.patch View File

@@ -0,0 +1,24 @@
1
+--- a/src/system.h
2
++++ b/src/system.h
3
+@@ -83,10 +83,6 @@
4
+ #include <linux/sysinfo.h>
5
+ #endif
6
+ 
7
+-#ifdef HAVE_SYS_SYSINFO_H
8
+-#include <sys/sysinfo.h>
9
+-#endif
10
+-
11
+ #ifdef HAVE_TIME_H
12
+ #include <time.h>
13
+ #endif
14
+@@ -139,6 +135,10 @@
15
+ #include <linux/un.h>
16
+ #endif
17
+ 
18
++#ifdef HAVE_SYS_SYSINFO_H
19
++#include <sys/sysinfo.h>
20
++#endif
21
++
22
+ #elif defined (__FreeBSD__)  || defined (__APPLE__) || defined (__OpenBSD__) || defined (__NetBSD__) 
23
+ #include <net/if.h>
24
+ #include <net/bpf.h>