瀏覽代碼

Merge pull request #295 from Adze1502/master

mwan3: update to version 1.5-5
sbyx 10 年之前
父節點
當前提交
34fd74553a
共有 2 個檔案被更改,包括 5 行新增5 行删除
  1. 1
    1
      net/mwan3/Makefile
  2. 4
    4
      net/mwan3/files/etc/hotplug.d/iface/15-mwan3

+ 1
- 1
net/mwan3/Makefile 查看文件

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=mwan3
11 11
 PKG_VERSION:=1.5
12
-PKG_RELEASE:=4
12
+PKG_RELEASE:=5
13 13
 PKG_MAINTAINER:=Jeroen Louwes <jeroen.louwes@gmail.com>
14 14
 PKG_LICENSE:=GPLv2
15 15
 

+ 4
- 4
net/mwan3/files/etc/hotplug.d/iface/15-mwan3 查看文件

@@ -69,7 +69,7 @@ mwan3_set_iface_iptables()
69 69
 {
70 70
 	local local_net local_nets
71 71
 
72
-	local_net=$($IP route list dev $DEVICE scope link | awk '{print $1}' | egrep '[0-9]{1,3}(\.[0-9]{1,3}){3}')
72
+	local_nets=$($IP route list dev $DEVICE scope link | awk '{print $1}' | egrep '[0-9]{1,3}(\.[0-9]{1,3}){3}')
73 73
 
74 74
 	if ! $IPT -S mwan3_iface_$INTERFACE &> /dev/null; then
75 75
 		$IPT -N mwan3_iface_$INTERFACE
@@ -79,10 +79,10 @@ mwan3_set_iface_iptables()
79 79
 	$IPT -D mwan3_ifaces -i $DEVICE -m mark --mark 0x0/0xff00 -j mwan3_iface_$INTERFACE &> /dev/null
80 80
 
81 81
 	if [ $ACTION == "ifup" ]; then
82
-		if [ -n "$local_net" ]; then
83
-			for local_nets in $local_net ; do
82
+		if [ -n "$local_nets" ]; then
83
+			for local_net in $local_nets ; do
84 84
 				if [ $ACTION == "ifup" ]; then
85
-					$IPT -I mwan3_iface_$INTERFACE -s $local_net -m mark --mark 0x0/0xff00 -m comment --comment "$INTERFACE" -j MARK --set-xmark 0xff00/0xff00
85
+					$IPT -I mwan3_iface_$INTERFACE -s $local_net -m mark --mark 0x0/0xff00 -m comment --comment "default" -j MARK --set-xmark 0xff00/0xff00
86 86
 				fi
87 87
 			done
88 88
 		fi