소스 검색

add kplex: NMEA-0183 multiplexer and router

Signed-off-by: Nuno Goncalves <nunojpg@gmail.com>
Nuno Goncalves 9 년 전
부모
커밋
3520ff67d8
1개의 변경된 파일47개의 추가작업 그리고 0개의 파일을 삭제
  1. 47
    0
      net/kplex/Makefile

+ 47
- 0
net/kplex/Makefile 파일 보기

@@ -0,0 +1,47 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+
7
+include $(TOPDIR)/rules.mk
8
+
9
+PKG_NAME:=kplex
10
+PKG_VERSION:=20150728
11
+
12
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
13
+
14
+PKG_SOURCE_PROTO:=git
15
+PKG_SOURCE_URL:=https://github.com/stripydog/kplex.git
16
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
17
+PKG_SOURCE_VERSION:=fec47cd1877ec7903969adefa4220838a706d940
18
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
19
+
20
+PKG_LICENSE:=GPL-3.0+
21
+PKG_LICENSE_FILES:=COPYING
22
+
23
+PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+define Package/kplex
28
+  SECTION:=net
29
+  CATEGORY:=Network
30
+  TITLE:=NMEA-0183 multiplexer and router
31
+  DEPENDS:=+libpthread
32
+  URL:=http://www.stripydog.com/kplex/
33
+endef
34
+
35
+define Package/kplex/description
36
+  Kplex is a program for combining and routing NMEA-0183 data to and from multiple
37
+  sources and destinations. kplex inputs and outputs may be any of Serial lines,
38
+  Pseudo Terminals (ptys), Network Interfaces and Files.
39
+endef
40
+
41
+
42
+define Package/kplex/install
43
+	$(INSTALL_DIR) $(1)/usr/bin
44
+	$(INSTALL_BIN) $(PKG_BUILD_DIR)/kplex $(1)/usr/bin/
45
+endef
46
+
47
+$(eval $(call BuildPackage,kplex))