Sfoglia il codice sorgente

libao: import from oldpackages, upgrade to 1.2.0, add license, pkg maintainer

Signed-off-by: Ted Hess <thess@kitschensync.net>
Ted Hess 10 anni fa
parent
commit
355bd4e41c
1 ha cambiato i file con 67 aggiunte e 0 eliminazioni
  1. 67
    0
      libs/libao/Makefile

+ 67
- 0
libs/libao/Makefile Vedi File

@@ -0,0 +1,67 @@
1
+#
2
+# Copyright (C) 2006-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libao
11
+PKG_VERSION:=1.2.0
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://downloads.xiph.org/releases/ao/
16
+PKG_MD5SUM:=9f5dd20d7e95fd0dd72df5353829f097
17
+
18
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
19
+
20
+PKG_LICENSE:=GPL-2.0
21
+PKG_LICENSE_FILE:=COPYING
22
+
23
+PKG_FIXUP:=autoreconf
24
+PKG_INSTALL:=1
25
+
26
+include $(INCLUDE_DIR)/package.mk
27
+
28
+define Package/libao
29
+  SECTION:=libs
30
+  DEPENDS:=+alsa-lib
31
+  CATEGORY:=Libraries
32
+  TITLE:=A cross platform audio library
33
+  URL:=http://www.xiph.org/ao/
34
+endef
35
+
36
+define Package/libao/description
37
+	Libao is a cross-platform audio library that allows programs to
38
+	output audio using a simple API on a wide variety of platforms.
39
+endef
40
+
41
+CONFIGURE_ARGS += \
42
+	--enable-shared \
43
+	--enable-static \
44
+	--disable-esd \
45
+	--disable-arts \
46
+	--disable-nas \
47
+	--disable-pulse
48
+
49
+TARGET_CFLAGS += $(FPIC)
50
+
51
+define Build/InstallDev
52
+	$(INSTALL_DIR) $(1)/usr/include
53
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/ao $(1)/usr/include/
54
+	$(INSTALL_DIR) $(1)/usr/lib
55
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libao.{a,so*} $(1)/usr/lib/
56
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
57
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/ao.pc $(1)/usr/lib/pkgconfig/
58
+endef
59
+
60
+define Package/libao/install
61
+	$(INSTALL_DIR) $(1)/usr/lib
62
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libao.so.* $(1)/usr/lib/
63
+	$(INSTALL_DIR) $(1)/usr/lib/ao/plugins-4
64
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/ao/plugins-4/lib*.so $(1)/usr/lib/ao/plugins-4/
65
+endef
66
+
67
+$(eval $(call BuildPackage,libao))